This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 11 replies, has 4 voices.

Last updated by Sumit 1 month ago.

Assigned support staff: Sumit.

Author Posts
April 28, 2018 at 10:31 am #1874776

dominikS-21

Hello Team.

Visual composer post masonry grid loading very slow after install WPML plugin.
hidden link this is place where grid not loading and others html is loaded.

Thanks

April 30, 2018 at 5:23 pm #1902587

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

Please go to WPML -> Languages and scroll down to the Language Filtering for Ajax section. Check the box to enable "Store a language cookie to support language filtering for AJAX".

When you try to load this page, are you seeing any errors in your browser console? Here is some information about how to view your browser console: hidden link

Please enable the WordPress debug log. This will allow us to see if any PHP errors are being produced. More Info: https://codex.wordpress.org/Debugging_in_WordPress

1. Edit wp-config.php and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

2. Browse to the page with the issue and/or reproduce the issue.

3. Locate the debug log in: /wp-content/debug.log

4. Paste the latest lines here. No need to paste the entire log file, just 50 lines or so will do. Please censor any sensitive information.

Lastly, I'd like to have you try a few things so we can try to isolate the issue. This is just to help me identify if it might be a conflict with another plugin or theme that is causing the problem.

** IMPORTANT ** Please backup a working copy of site files and database before continuing.

Update all WPML plugins & WordPress core.

Disable all plugins except WPML related , the Visual Composer plugin and then temporarily change the theme to a default WordPress such as TwentyFifteen. With these settings, is the issue resolved?

May 1, 2018 at 2:35 pm #1913880

dominikS-21

I have checked with wordpress default theme and only Visual composer and WPML plugins. Speed is still not loading fast and when i deactivate WPML Multilingual CMS then speed is ok.
and i have also setup debug error but does not create debug.log file?

May 1, 2018 at 4:05 pm #1915349

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

To best troubleshoot the issue, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.

Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will also need the username and password of an account that was created BEFORE creating the duplicator package.

I will enable the next reply to be private so only you and I have access to it!

May 2, 2018 at 4:34 pm #1939217

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for sharing the Duplicator files. I was able to reproduce the issue locally with minimal settings and also on a fresh install. I have escalated this to our Compatibility team, and as soon as I have more information I will update here. Thanks for your patience.

May 3, 2018 at 10:50 am #1954589

dominikS-21

how long to do this process ?

May 7, 2018 at 5:50 am #2002885

dominikS-21

I need solution when you will do this, we are very late?

May 8, 2018 at 3:18 pm #2034955

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Our developers are currently troubleshooting this issue and will respond as soon as I have more information.

May 10, 2018 at 10:16 am #2069366

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

I am Sumit from 2nd tier support.

As per my analysis, there is 1.5 seconds difference in Ajax request response time. We can't make it 0 because when WPML is activated it will definitely take some time. Not even WPML any theme plugin takes some amount of time.
However, we have some reports where we see some performance problems with WPML and we are working on it to improve the performance.
This is being done by our development team.

I will ask you to please wait till we release a new improved version and I believe this will minimize this difference.

I will keep you posted on the status of this issue.

Thanks

July 9, 2018 at 3:01 pm #2476851

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

This issue should be resolved with the latest versions of WPML plugins. Please update and let me know if you are still seeing issues. Thanks!

September 11, 2019 at 4:27 pm #4555283

dr-olimpiuH

Hello,
I have the same issue as is listed here. Is there a resolution for it?
thank you.

September 12, 2019 at 2:51 pm #4562057

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

This issue has been fixed in the latest version of WPML plugin. If you still have this issue then please open a new ticket.

Thanks