This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Visual Composer & Woocommerce compatibility issue . Can't switch tabs . Can't change variations

Solution: Update WPML , WCML to the latest version

This topic contains 8 replies, has 3 voices.

Last updated by jaehyukL 3 years, 11 months ago.

Assigned support staff: Mohammed.

Author Posts
October 6, 2015 at 8:09 pm #719157

jaehyukL

I am trying to: use WPML on woocommerce / site

URL of (my) website where problem appears: alltrueorganic.com

I expected to see: Visual composer working as normal & edit woocommerce products at default language. I know, i have to use woocommerce multilingual for other languages. But, i could not edit default language(English) products.

Instead, I got: see attached images (error-woo.jpg) & (error-vc.jpg)

After wpml & wpml woocommerce installation, there are some error with visual composer.
Site Brief info :
Theme name : 8Theme- legenda - hidden link
Site Address 1)
hidden link - with WPML & Woocommerce multilingual -> this site has a problem. I want to fix the problem.
Site Address 2)
2) hidden link - without WPML & Woocommerce multilingual -> this site is a sample. Why WPML has a problem. Woocommerce & VC is working fine on this site.

Brief problem comment:
Visual composer (4.7.4. latest one), but 4.6.0 to 4.7 has a problem (i tested with previous VC).
WooCommerce - I cannot add images, edit weight or attributes section - cannot select it.

----------------------------------------------------------------------------------
1. Visual composer is not cooperate with previous content. Visual composer show empty content and visual/text editor show previous contents. So, if i add some contents on VC (Visual Composer), then, previous contents automatically deleted. I installed latest VC and
WPML version is 3.2.7

See below link image
hidden link

----------------------------------------------------------------------------------
2. I could not edit exiting products (default language product, i follow the comment of wpml, but it is not matter. I want to edit default language product.

After woocommerce-multilingual 3.6.11, if i want to change weight, stock, categories, i should use 'Quick-Edit' on product list page. Even, i could not touch attributes for variable products.

See below pic
hidden link

But, if i disable the Visual composer, i could edit contents – gallery and weight etc.
But, featured image section disappear.

Without WPML, site is fine.
I use same theme at trueusorganic.com with same contents - pages & products.
Everything is fine.

----------------------------------------------------------------------------------
Site (alltrueorganic.com) is okay to run, but editing mode has a problem after WPML & Woocommerce multilingual installation.

I use
sitepress-multilingual-cms.3.2.7
woocommerce-multilingual.3.6.11

So, any idea ?

October 8, 2015 at 10:06 am #720368

Mohammed
Supporter

Languages: English (English ) Arabic (العربية )

Hello Jaehyuk,

Thank you for contacting WPML support.

I'm sorry to say that: it's a JavaScript issue with WPML and Visual Composer. But the good news is that this problem is already escalated to our development team and they are aware of it and working hardly to solve it as soon as possible.

I will update you if any update is available.

Thanks.

October 24, 2015 at 11:55 pm #732057

jaehyukL

Hello Mohammed,
Any updated news ?
I could not add any new product with WPML Woocommerce multilingual.
This is the serious issue.

I tested with other sites. It is is same issue.

October 26, 2015 at 1:50 pm #732667

heleneT

I have the same issue... this is urgent as we cannot have multilingual and woocommerce at the same time!
Please respond

October 26, 2015 at 3:07 pm #732767

Mohammed
Supporter

Languages: English (English ) Arabic (العربية )

Hi Jaehyuk and Helene,

This issue will be solved in the next release, But we prepared a workaround that may fix the issue temporarily until we launch the release.

I will need a snapshot of your website to test that the fix will work properly on your installation.

For this you'll need to temporarily install a plugin called "Duplicator" on your site. This will allow you to create a copy of your site and your content. You can provide me with the snapshot following these directions:
If you already know how Duplicator works ( http://wordpress.org/plugins/duplicator/ ), please skip the following steps and just send me the installer file and the zipped package you downloaded.

:: Duplicator instructions
. From WordPress plugin page, look for "Duplicator" and install it
. Once installed, you get a new main menu "Duplicator"
. Chose "Packages"
. Click on the first button you find in the toolbar on the right ("Create Package")
. Give it a name or leave it as is
. Click on "Create Package Set"
. Wait until the package is ready
. Click on "Installer", then on "Package": the first one is just a php script, the second one is a zip file containing everything you need
. Send me both files (you probably want to use DropBox, Google Drive, or similar services, as the snapshot file will be quite big , you can also exclude the images if the file is very big )
IMPORTANT: remember to create or keep an admin account for me before creating the snapshot, or I won't be able to log-in. You may delete the new admin account once the snapshot has been built.

I will set the next reply as a private reply so you will able to provide a link to download the duplicator package.

@helene I will deploy the fix on Jaehyuk installation and once it's solved, I will share the solution for you.

Thanks and Best Regards

October 29, 2015 at 12:43 pm #735468

Mohammed
Supporter

Languages: English (English ) Arabic (العربية )

Hi Jaehyuk and Helene,

Thank you Jaehyuk for the information, I will not use the duplicator package because the workaround is officially released . So no need to test before I provide you the workaround.

Please go to this errata page and follow the steps included there: https://wpml.org/errata/variations-tab-not-effective-when-visual-composer-used-with-wc-products/

It will solve the Visual Composer issue.

Thanks

November 3, 2015 at 6:36 pm #738759

jaehyukL

Hi Mohammed,
I checked this code with V.C. But, the issue is not solved on VC.4.8.0.

This code work for V.C. 4.7.4, not 4.8.0. I tested with both VC version and found out VC 4.8.0 show same problem.

So any idea ?

November 4, 2015 at 11:40 am #739281

Mohammed
Supporter

Languages: English (English ) Arabic (العربية )

Hi Jaehyuk ,

This is a recurring issue with V.C. 4.7.4 , So, we provided this workaround to solve the issue temporary.

We already launched a beta version that fixes the issue , Please check the Betas section here : https://wpml.org/account/downloads/

But we don't recommend installing beta versions on a live website .
I recommend you to downgrade VC to 4.7.4 and deploy the workaround or wait until we launch the official release.

Thanks.

November 19, 2015 at 12:53 am #749699

jaehyukL

Finally,
After updating 2.8.1 of VC & WPML woocommerce, issue is gone and thank you for Mohamed.
Thanks,