This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: after completing an order in the second language, the mail you get from WC PDF Product Voucher is in the default language, even if the mail text is translated in String Translation.

Solution: increase the WP Memory Limit (see below)

Relevant Documentation: https://wpml.org/forums/topic/voucher-e-mail-texts-is-not-translated-to-ru-language/#post-3838657

This topic contains 2 replies, has 2 voices.

Last updated by martinO-4 5 months ago.

Assigned support staff: Laura.

Author Posts
May 17, 2019 at 5:10 pm #3836193

martinO-4

I am trying to: WC PDF Product Voucher email texts are translated to Estonian and Russian in String Translation page.

Link to a page where the issue can be seen: hidden link

After purchasing order from RU e-shop page you got emails: completed order email text are Russian, but voucher email texts are Estonian. I don't know why these emails are in different language. WordPress default language is set to Estonian.

May 18, 2019 at 10:07 am #3838657

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

thanks for contacting us.

The WP Memory Limit needs to be increased. PHP memory limit is fine but WordPress uses 40Mb as default. Minimum requirements for WPML are 128Mb.
Add this near the top of wp-config.php file (after the php opening tag) to increase WP memory:

/** WP Memory Limit */
define( 'WP_MEMORY_LIMIT', '256M' );

The wp-config.php file is located in your WordPress root directory. It's the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.
You can check the current WP Memory Limit value from WPML -> Support in the Info section
More info here:
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP
https://wpml.org/home/minimum-requirements/

If this doesn't help, you might try a compatibility test:
- backup your site
- disable all plugin except WPML and its addons
- switch to a default theme like TwentySeventeen
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again
- lastly, reactivate your theme

Or I should ask you to reproduce the issue on a fresh install.

May 20, 2019 at 8:22 am #3844709

martinO-4

My issue is resolved now, thank to increasing WP Memory Limit. Thank you!