Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Cannot save A different domain per language option in languages.

Solution: Un-tick the validate option after setting the domains correctly.

Here's an outline of steps :

1. Go to WPML >> Languages > URL Option and find option A different domain per language

2. Afterwards, try to save the needed option, but uncheck the validate option first

3. You'll able to save this URL option

This topic contains 25 replies, has 3 voices.

Last updated by avishai-samB 5 years ago.

Assigned support staff: Ahmed Mohammed.

Author Posts
October 30, 2014 at 9:53 am #502484

avishai-samB

Hi,

I tried to make a subdomain for any language in my website.
I saw this guide: http://wpml.org/faq/server-setting-for-languages-in-different-domains/
but this guide explain how to do it on Apache server and I using Nginx server.

Please help me to configure it on my Nginx server.

Thank you !

October 30, 2014 at 10:27 am #502531

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

Hello and thank you for contacting us.
Can you check if this would help you? - hidden link
adding this settings:

server_name ~^(?<vhost>.*)$;
root /srv/www/$vhost;
access_log /var/log/nginx/$vhost.access.log;

I hope that this helps you.

October 30, 2014 at 11:44 am #502640

avishai-samB

Hi George,
Thank for your quick reply !

I think that I do something wrong. Can you help me with it please?
I uploaded a screenshot for all of the files (/etc/hosts + nano /etc/nginx/nginx.conf)
Please tell me what do I need to do.

And please tell me what I need to set up on my DNS manager.

Thank you !

October 30, 2014 at 12:03 pm #502653

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

I think that you have to configure DNS Wildcard domain - you can see example here: http://codex.wordpress.org/Configuring_Wildcard_Subdomains
and point it to your server address. Also maybe you should configure this inside the hosts file of your server. You can read also here: http://wpml.org/faq/server-setting-for-languages-in-different-domains/

October 30, 2014 at 12:14 pm #502669

avishai-samB

OK. I added a wildcard to my domain and all the subdomains pointing to my domain.
But still can't save on WPML -> Languages the changes.

Do you saw my screenshots? everything set up good?

October 30, 2014 at 12:18 pm #502673

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

I have seen your screenshots, and I cannot find anything wrong with them.
Can you try to flush your servers dns cache? hidden link
It might help.
Try to access anydomain.yourdomain.tld and anydomain2.yourdomain.tld if you can - then it is probably correctly set-up.

October 30, 2014 at 12:38 pm #502689

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

Please see also this: hidden link
It might help you because there might be some version differences that I was not aware of.

October 31, 2014 at 3:33 pm #503676

avishai-samB

Hi,

I tried everything you wrote me and still don't succeed.
There isn't some guide for nginx users? or some supporter that know to configure it?
Really need your help !

Thank you !

October 31, 2014 at 3:45 pm #503691

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

I will escalate your issue to second level support.

October 31, 2014 at 3:47 pm #503695

avishai-samB

Thank you about your try George.
Really appreciate it.

November 1, 2014 at 10:36 am #503867

avishai-samB

Can I ask when the second level supporter will contact me?

Thank you !

November 3, 2014 at 9:32 am #504305

avishai-samB

Hello?! Anyone?!?!

November 3, 2014 at 12:38 pm #504466

Ahmed Mohammed
Supporter

Timezone: Europe/Rome (GMT+01:00)

Dear avishai-samB, This is Ahmed and I'm taking care of this, hope it's OK!

We're not working on weekends, and I just got your ticket today, I'll update you today if I've more information.

Thanks

November 3, 2014 at 6:01 pm #504831

Ahmed Mohammed
Supporter

Timezone: Europe/Rome (GMT+01:00)

Thanks for the wait, can you access the subdomains you've created ? You can create and index file and write anything inside it and visit your subdomain and check if the file exists.
If you're not able to browse the created file, then you may need to contact your hosting provider.

November 4, 2014 at 8:44 am #505081

avishai-samB

Hi Ahmed,

Thank you for your help !
I have been created cname subdomain like George asked me to do.
All my subdomain (example.domain.com, anything.domain.com) refers to domain.com.
Do I need to change it?

Thank you !
Ohad.