This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.18 hours from now. Thank you for your understanding.

This topic contains 6 replies, has 2 voices.

Last updated by Andreas W. 4 months, 2 weeks ago.

Assigned support staff: Andreas W..

Author Posts
January 21, 2019 at 1:02 pm #3112479

andrep-14

I am trying to: update a translation

Link to a page where the issue can be seen:
hidden link

I expected to see:
the same layout as portuguese page

Instead, I got:
Only a few lines translated
different layout

January 21, 2019 at 2:38 pm #3112825

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

Thank you for contacting WPML Support.

In order to undo the translation simply delete the translated page. Did you try to translate the page using the WPML Translation Editor or did you translate it manually using the native WordPress Editor? The WPML Translation Editor can be enabled at WPML -> Settings -> how to translate posts and pages.

Further, could you please increase your Memory Limit and WP Memory limit to 256M? 128M is the minimum required by WPML.
Your current values are:

MemoryLimit 256M
WP Memory Limit 40M
Add this code to your wp-config.php to increase WP memory:

/* Memory Limit /
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/ That's all, stop editing! Happy blogging. /

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly.
If you can get even higher values It would be great.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means,
with a default theme and not other plugins installed.

I would also advise your to change the settings for MaxInputVars to the value "3000". You can find the setting sinside of your php.ini files. In some cases you will need to take the edit on your htaccess file.

For more information please read this article.

hidden link

Let me know if you need any further assistance.

Kind regards
Andreas

January 21, 2019 at 2:56 pm #3112882

andrep-14

Hi there,

If i delete the page I will have nothing. I had the page translated. I just tryed to change one phrase and then all the layout changed. Did you see the pages? English and PT versions?

So.. if there is no way to undo, as your answer was to delete the page. ?!

So How to make all the layout appear to translation? step by stepplease because this WPML site is so confusing.

Thanks

January 22, 2019 at 3:56 pm #3117323

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

Thank you for your message.

I am sorry for the confusion I may have caused on my earlier reply. The main issue that you were experiencing must have been caused due to the WP_memory limit and the MaxInputVars setting.

I can see now that the site hidden link and also the Portuguese version are showing up in the same way, correct?

Did you still spot out some sections where the style of the page does not match the original content?

I would also kindly remind you that WPML 4.1.4. has been released today. Please make sure to update the plugin.

Kind regards
Andreas

January 22, 2019 at 4:04 pm #3117341

andrep-14

Hi there,
the portuguese e english versions are the same because I did all the change manually by changing the wp language and doing all again.. the wrong way. As i have that plugin that shoud be helping me.
So I Still have the same question:
How to make all the layout/content appear for translation? step by step please because this WPML site is so confusing.
Now I I'll try that with another page
tks

January 22, 2019 at 5:03 pm #3117485

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

After having a more detailed look in our forum regarding compatibility with the X Theme I realized that we do have an open errata about issues with the translation of this theme. The shortcodes used by the theme authors to display the theme on translated pages have changed in the latest version of the theme.

Our compatibility team is working on a solution for this issue with the release of WPML 4.2.0. and in the meantime we can only advise to use a previous version of the X Theme or translating the content manually with the native WordPress Editor.

Please have look into the following documentation for more details:

https://wpml.org/errata/cornerstone-shortcodes-arent-rendered-in-the-translated-pages/

We are sorry about the inconveniences and hope for your understanding.

Kind regards
Andreas

June 6, 2019 at 9:51 pm #3972289

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

***STATUS UPDATE***