This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Mihai Apetrei 3 months, 3 weeks ago.

Assigned support staff: Mihai Apetrei.

Author Posts
June 25, 2019 at 1:53 pm #4085109

jordyt-2

I am trying to: translating pages

Link to a page where the issue can be seen: non

I expected to see: box original languages to new languages

Instead, I got: a redirect to make a new page

June 25, 2019 at 2:17 pm #4085381

jordyt-2

srry for the fotos iam using a dubble screen ( for WPML.jpg and wpml 2.jpg --> only the left side counts )

June 25, 2019 at 4:48 pm #4086267

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

What you would like to see I think is the WPML Classic Translation Editor layout (or even the WPML Advanced Translation Editor would have the two languages side by side, as you want).

So can you please go to WPML > Settings > How to translate posts and pages > and select the "Use WPML's Classic Translation Editor" option and then scroll down a bit and save the settings?

After this, can you please try to click on the + icon once again trying to translate something and see if things work as expected?

Please let me know how that goes.

Kind regards,
Mihai Apetrei

June 25, 2019 at 8:29 pm #4087095

jordyt-2

hey i try but now i have only a title to edit and below for the page I have 2 screens 1 with the same cop as the other ->>> for original and translation ill get in both boxes --->>>

[section bg_color="rgb(242, 242, 246)" padding__sm="0px"]

[ux_banner height="500px" bg="3000" bg_size="original" bg_overlay="rgba(0, 0, 0, 0.22)" bg_overlay__sm="rgba(0, 0, 0, 0.2)" bg_pos="8% 5%" border="0px 0px 0px 0px" border_margin="-28px 0px 0px 0px"]

[text_box width="47" width__sm="88" scale="142" position_x="100" position_x__sm="50" position_y="50" position_y__sm="95" text_depth="3" border="0px 0px 0px 0px"]

<h5 class="uppercase" data-line-height="xs">A NEW SHADE A NEW</h5>
<h3 class="lead uppercase">fresh style</h3>
[button text="Merchandise" color="white" style="outline" radius="99" depth="3" link="hidden link"]

[/text_box]

[/ux_banner]
[title style="center" text="CATEGORIES" tag_name="h1" color="rgb(0, 0, 0)" margin_top="30px" margin_bottom="51px" size="145"]

[ux_product_categories style="default" type="masonry" col_spacing="large" depth="3" orderby="date" order="desc" image_radius="2" image_overlay="rgba(0, 0, 0, 0.18)" image_hover="overlay-remove-50" image_hover_alt="zoom-long" text_bg="rgb(240, 237, 239)"]

[title style="center" text="WANNABE FIRST" tag_name="h2" color="rgb(0, 0, 0)" margin_top="25px" margin_bottom="25px" size="142"]

[ux_banner height="392px" bg="3977" bg_size="original" bg_color="rgb(209, 209, 209)" bg_overlay="rgba(8, 4, 58, 0.34)" bg_overlay__sm="rgba(8, 4, 58, 0.26)" bg_pos="58% 11%" parallax="9" border="0px 22px 0px 22px"]

[text_box position_x="50" position_y="15"]

[gap height="22px"]

instead of text to edit,.. it whant me to edit the hole page

June 26, 2019 at 8:59 am #4090619

jordyt-2

can't i make a new ticket to give permission to you or someone of the support team(for the back end and fully use of the site) to take a look and perhaps set it up properly so I can do the translation (have deleted the plugins and using a backup version now xd)

June 26, 2019 at 3:16 pm #4093529

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the information.

I will enable the private fields below, just please make sure that you have everything installed (WPML plugins, theme and the plugins the theme is using).

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai Apetrei

June 28, 2019 at 5:27 pm #4109649

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the credentials.

I can confirm that they are working.

From what I can see, if I go here (hidden link), the "Use WPML's Translation Editor" area was set to off (attaching screenshot).

I enabled that and things look on 2 columns as expected (hidden link).

Can you please check and let me know if that looks of your you, too?

I will be waiting for your response.

Just a note that I won't be working on the weekend so I will be able to get back to you at the beginning of next week.

Kind regards,
Mihai

June 28, 2019 at 7:57 pm #4110099

jordyt-2

yes its look the same way over here, and this is where the oddity comes from because if I look to a tutorial or something else to get information from I always see multiple boxes where i don't c the ccs code but only the h1,h2,h3 paragraphs to translate left side,. right side,. and that would be lovely (Y)

July 1, 2019 at 5:47 pm #4121501

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Now I totally understand what you meant.

Yes, that would be the normal / more usual way things should look (I think you are referring to all the WPML tutorials referring to popular content builders like WP Bakery, Divi builder, Elementor and so forth where the WPML Classic Editor is used on two columns and loads directly the strings and not the shortcodes) but from what I can see, Flatsome is not part of our official WPML-compatible themes directory here at the moment (https://wpml.org/documentation/theme-compatibility/).

So, taking into consideration that the Flatsome theme is using the UX Frontend Builder, I think that's the best way things can be done at the moment until the developers from Flatsome don't do any change to this.

Instead of using the WPML Classic Editor, you could use this duplication method in the link below and that might make things easier to use for you where you could simply duplicate the page you've built with the content builder of the theme and then go to the duplicated page and click on the content block and simply change the content:
https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/using-content-duplication/

Regarding a better compatibility with the content builder, I'd suggest you contact the plugin authors and recommend them to join our 'Go Global' program (https://wpml.org/documentation/theme-compatibility/go-global-program/) where our Compatibility developers will help them make their plugin 100% compatible with WPML for free.

Or maybe their support team might have any recommendation?

I hope that you will find these steps helpful 🙂

Please let me know how it goes.

Kind regards,
Mihai