This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Noman 1 year ago.

Assigned support staff: Noman.

Author Posts
October 5, 2018 at 9:28 pm #2791731

emiliec-2

I am trying to: instal wpml

Link to a page where the issue can be seen:
it 's in the admin in local

I expected to see:
plugin installed

Instead, I got:
this error
Warning: require(/app/public/wp-content/plugins/sitepress-multilingual-cms/vendor/composer/../yoast/whip/src/facades/wordpress.php): failed to open stream: No such file or directory in /app/public/wp-content/plugins/sitepress-multilingual-cms/vendor/composer/autoload_real.php on line 66 Fatal error: require(): Failed opening required '/app/public/wp-content/plugins/sitepress-multilingual-cms/vendor/composer/../yoast/whip/src/facades/wordpress.php' (include_path='.:/usr/share/php:/www/wp-content/pear') in /app/public/wp-content/plugins/sitepress-multilingual-cms/vendor/composer/autoload_real.php on line 66

October 8, 2018 at 1:38 pm #2796169

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. Could you please try below steps:

1. Backup your database – see for example: http://wordpress.org/extend/plugins/wp-db-backup/

2. Deactivate the existing WPML plugin and add-ons.

3. Delete the plugin files – this does not delete your translations. You will simply delete the plugin files from your "wp-content/plugins" folder, NOT the database records.

4. Download the updated plugins from our servers (https://wpml.org/account/downloads/) and upload them to the plugin directory.

5. Activate the WPML plugin and add-ons

6. Please clear all sort of caches in your site plugin cache / CDN cache (if any) / browser cache and then see if it resolves the issue afterwards.

If still issue persists:

- Please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Sixteen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

- Please add the debug report in the Debug Information box. I have also enabled debug info box for your next reply: https://wpml.org/faq/provide-debug-information-faster-support/

Thank you

October 9, 2018 at 4:13 pm #2801006
emiliec-2

Thank you. it was really clear and usefull. The plugin wpml is installed, I set up the translator + I set up the widget in french or english.
but I have 2 issues :
FIRST : I don't see how to translate the whole website except widgets. All my content is in the home page. I need to use customize fonction with illdy theme to add content and there is not choice to pick up the language there.
SECOND : I see "language translator" in my menu+ I see "french" first, english in second, even though I choose the opposite, and english doesn't link to anything.

thank you for your help!
Émilie

New threads created by Noman and linked to this one are listed below:

https://wpml.org/forums/topic/customizer-section-translation-and-change-language-order/

October 10, 2018 at 12:02 pm #2804130

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Glad to hear that you have installed WPML plugin successfully. To handle other issues, I have created a new ticket since this is a separate issue. Here is the link to the new ticket:
https://wpml.org/forums/topic/customizer-section-translation-and-change-language-order/

You may mark this current ticket as resolved and we will continue to work on the new ticket.

Thank you