Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 3 voices.

Last updated by Andrés 4 years ago.

Assigned support staff: Andrés.

Author Posts
October 29, 2015 at 1:58 pm #735564

Barry

Hi there... I get this message:

Warning: getimagesize(C:\domains\2016ebc.com\wwwroot/wp-content/hidden link): failed to open stream: No such file or directory in C:\domains\2016ebc.com\wwwroot\wp-content\themes\atelier\includes\plugins\aq_resizer-1x.php on line 74

And it happens only when i use WPML.
Hope you can help me

greetings
Barry

October 30, 2015 at 1:11 pm #736383

David
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

The problem seems to be in aq_resizer-1x.php and the way it calculates the path.

Can you share a piece of code around line 74 and a few lines before that?

Thanks

November 2, 2015 at 7:51 am #737151

Barry

//get image info
$info = pathinfo($img_path);
$ext = $info['extension'];
line74> list($orig_w,$orig_h) = getimagesize($img_path);

//get image size after cropping
$dims = image_resize_dimensions($orig_w, $orig_h, $width, $height, $crop);
$dst_w = $dims[4];
$dst_h = $dims[5];

November 2, 2015 at 4:38 pm #737648

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Hello Barry,

As David is not available today, I would like to take care of your case, if you agree, of course.

I guess you are using the following Aqua-Resizer, and it's pretty probable that its not multilingual ready :
hidden link
It seems like a Compatibility issue, as it is not in our compatibility list:
https://wpml.org/documentation/plugins-compatibility/

However, I have noticed from your debug information, that you don't have WooCommerce Multilingual plugin installed. This plugin, in association with WPML package, will let WooCommerce shop become multilingual.

Before starting this process, I advise you to read carefully this document:
https://wpml.org/documentation/related-projects/woocommerce-multilingual/

And verify that all your setup is ready for start, to use WooCommerce Multilingual, you need to have the following plugins installed and activated:
WPML 3.2.7 or above
WPML String Translation 2.2.6
WPML Translation Management 2.0.5
WPML Media Translation 2.1.13
WooCommerce Multilingual 3.7
WooCommerce

Even if this doesn't solve your issue, it would be a necessary practice for continue translating your shop.
Please, let me know your findings.

Regards,
Andrés

November 3, 2015 at 9:33 am #738106

Barry

Hi there,

Thanks foor the feedback. I activated all the WPML plugins and updated them. But still the same error. The theme does support WPML.

Regards,
Barry

November 3, 2015 at 9:36 am #738110

Barry

The strange think is... it happens only with the TEAM option. The rest of the site works fine. I also ask the theme builder, if they have a solution.

November 3, 2015 at 2:07 pm #738429

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

I would like to request temporary access (wp-admin and FTP) to your test site to take better look at the issue, could you please indicate me how to replicate this behaviour ?

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok for you.

*Important: Be sure to backup your site and database first before you proceed!
You can use a plugin for this if you like. You can use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

Privacy and Security when Providing Debug Information for Support:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

November 3, 2015 at 7:36 pm #738804

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Hello Barry,

I visited your site and I have hidden those messages adding this line at your wp-config.php file:

define( 'WP_DEBUG_DISPLAY', false );

However they are still there but not visible.

From what I've seen, it is associated to your theme, once you switch it to a WordPress default theme, they disappear. Could you please upgrade your theme and tell me if the problem is still present ?

For checking, please change the following line:

define( 'WP_DEBUG_DISPLAY', true );

Regards,
Andrés

The topic ‘[Closed] Warning: getimagesize’ is closed to new replies.