This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 5 replies, has 2 voices.

Last updated by Itamar 12 months ago.

Assigned support staff: Itamar.

Author Posts
October 5, 2018 at 12:36 am

Richard

I have WPML installed on a WP4.98 Multisite network with domain mapping and multi-domains active. I am just now configuring it on different subsites and setting up translation services, etc.

Most all of the sites are running Beaver Builder child Theme.

No translations exist on any site at this time.

Users can create subdomain sites on multiple base domains that they can choose from and then later they can map their site to a top level domain.

WPML has been activated and configured on selected sites across the network.

When configuring the languages tab settings ONLY the following sites present the warning "looks like languages per directories will not function." All other sites do not present the warning.

We do NOT currently have the box checked for the default language to be in a directory.

Rewrite rules appear to be working.

English and Spanish are configured languages on all sites, but the Spanish language is hidden on all sites including the ones displaying the warning. No Spanish translations currently exist.

hidden link

When WPML accesses hidden link it gets:
<!--hidden link;
The expected value is:
<!--hidden link;

hidden link

When WPML accesses hidden link it gets:
<!--hidden link;
The expected value is:
<!--hidden link;

hidden link

When WPML accesses hidden link it gets:
<!--hidden link;
The expected value is:
<!--hidden link;

Why does the diagnostic feature test against /es instead of the default url?

I am only submitting DEBUG information for one site.

Can you advise about this warning?

Thanks,
Phil D

October 7, 2018 at 7:34 pm #2794199

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Phil.

I'm trying to understand your setup and the problem that you have.
Can you please elaborate on the following points?
Why do you expect that a subdomain of a certain domain will get the value of a completely different domain?
For example, why do you expect to get hidden link for hidden link?
A subdomain functions as a stand-alone domain.
Please make sure that you are following our instructions on How to use WPML with different domains per language.
https://wpml.org/2016/04/use-wpml-different-domains-per-language/
The following message that you are getting seams alright to me.

<!--<em><u>hidden link</u></em>;

Does the option languages in folders not functioning on your site?

Regards,
Itamar.

October 15, 2018 at 6:49 pm #2818543

Richard

For example, why do you expect to get hidden link for hidden link?

We are using the DIRECTORY feature for additional languages, not additional domains for different languages.

The site's default language is English so it seems odd the message is referring to the url for the secondary language Spanish rather than the primary url for English.

I am not sure if it is working as we do not yet have any translations, I am just trying to determine why some sites are displaying this message when dozens of other sites do not display the message.

As I reported the appearance of the message appears to be on sub-domain sites which are mapped to another top level url.

October 16, 2018 at 11:24 am #2820712

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Phil and thanks for the extra details.

I'm consulting our second tier supporters about this issue.

Meanwhile, I would also like to ask you the following.
You wrote: "I am just trying to determine why some sites are displaying this message when dozens of other sites do not display the message.

As I reported, the appearance of the message appears to be on sub-domain sites which are mapped to another top level url."

So the other sites where you do not have this problem are configured differently?
I ask it because I thought that all of your sites are configured as sub-domain sites which are mapped to another top-level URL.

Thanks,
Itamar.

October 16, 2018 at 5:48 pm #2822025

Richard

Hello,

There are more than 60 sites on this multisite network.

Here are examples of sites that do NOT display a warning message

soobahkdo.biz
apply.wmdk.com
korea.wmdk.com
martialarts.qualityoflives.com
events.soobahkdo.org
festival.soobahkdo.org
kdjss.soobahkdo.org
legacy.soobahkdo.org
r1.soobahkdo.org
r2.soobahkdo.com
r3.soobahkdo.org
r4.soobahkdo.org
r5.soobahkdo.org
r6.soobahkdo.org
r7.soobahkdo.org
r8.soobahkdo.org
r9.soobahkdo.org
r10.soobahkdo.org

Here are examples of sites on the same multsite network that DO display a warning. Each of these sites has a top level domain mapped to a subdomain site on the network. The network has multiple base domains that users can create subsites on. (soobahkdo.org, wmdk.com,martialart.biz,academysbd.com, karatestudio.biz, qualityoflives.com and others)

karatefraud.com is mapped to fraud.martialart.biz
soobahkdo.com is mapped to hq.soobahkdo.org
worldmoodukkwan.com is mapped to wmdk.soobahkdo.org
moodukkwanmall.com is mapped to store.soobahkdo.org

We have not yet added any translations to any sites.

I am just trying to understand why some sites present the warning and others do not.

October 16, 2018 at 8:27 pm #2822337

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for the extra details.

So basically I understand that all the site in your multisite configured similarly and the problem only happens on some of them.
By the way, does besides the message in WPML -> Languages the site is operating correctly?

Our second tier noticed that there are missing “s” in HTTP protocol. For example, let's take this.
When WPML accesses hidden link it gets:
<!--hidden link;
The expected value is:
<!--hidden link;
You can see that it gets: <!--hidden link; and it should be <!--hidden link;.
Could you please go to Network Admin -> Sites -> All Sites and edit this specific site, then go to the 'Settings' tab and check if both 'Siteurl' and 'Home' are set with HTTPS?
Please see the attached screenshot.
They should both be with HTTPS, if not then change it to be HTTPS and see if the message disappears.

Thanks,
Itamar.

The topic ‘[Closed] Warning looks like languages per directories will not function’ is closed to new replies.