This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 25 replies, has 2 voices.

Last updated by Otto 12 months ago.

Assigned support staff: Otto.

Author Posts
October 20, 2018 at 10:37 am #2834023

ka-lunK

Tell us what you are trying to do?

When I tried to add translation on pages. It appears some warnings about MySQL, please have a look at the attached images.

Is there any documentation that you are following?

Is there a similar example that we can see?

What is the link to your site?
larossy.com

October 20, 2018 at 10:56 am #2834106

ka-lunK

These warnings sometimes disappear when I refresh the page, but will come back again so the refresh doesn't solve the problem.

October 20, 2018 at 1:11 pm #2834199

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

I could not reproduce the issue in a test WP installation. It looks like a compatibility issue.

To check it, if it is possible for you, do this test:
***Backup your site and DB before proceeding***

-Deactivate all the plugins but WPML and its add-ons
-Switch to a default WP theme (Twenty Sixteen for example)
-If the issue is gone, reactivate one at a time to see with which one is the conflict

Let me know your results, please.

Kind regards,

Otto

October 20, 2018 at 3:03 pm #2834322

ka-lunK

Hi Otto,

Thank you for your time replying my ticket on weekend!
I tried these steps and everything looks fine now. Will let you know if there is any warning.

Best,
Lawrence

October 20, 2018 at 4:12 pm #2834387

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

I am happy to hear that 🙂

Have a great weekend!

Kind regards,

Otto

October 21, 2018 at 9:46 am #2835373

ka-lunK

Hi,

It appears again right now. I haven't started translation yet as to see whether the warnings will come out again. However, it will disappear when I refresh the page. I'm wondering is it a big issue or not as it will disappear sometimes, so weird.

Best,
Lawrence

October 21, 2018 at 10:11 am #2835385

ka-lunK

I just found other post that some users got these warnings as well. This might be related to the memcache function from hosting server. I've disabled this function and asked them for any further assistance.

October 21, 2018 at 12:03 pm #2835507

ka-lunK

I got updated from hosting. Basically I'm using Siteground and they provide a cache plugin contain Memcached function which cause the warnings. I can now disable it for development purpose but it should be activated after development as it does a great job to boost the loading time.
Siteground said they couldn't find a way to fix this problem at their side as it is kind of compatibility issue. Do you guys have any solution to this issue?

October 22, 2018 at 1:14 pm #2838183

ka-lunK

Hi Otto,

It's a great troubleshooting method but I'm wondering the problem is caused by Siteground Memcached system, will this problem solved if I migrate it on cloudways server?
Also, should I enable the Memcached before migration?
Sorry I'm a noob on php/db/script so have no idea what steps should be done first.

Best,
Lawrence

October 22, 2018 at 1:24 pm #2838202

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

I think it should persist. Our server has Memcached 1.4 enabled.

Anyway, your point is valid. Still, I think it is worthy to try cloning the site and see if we can debug it in our test server, before asking you to log in into your site and check the issue. Makes sense?

If so, can you please proceed with the migration and let me know when it is ready?

Thanks!

Kind regards,

Otto

October 22, 2018 at 1:53 pm #2838303

ka-lunK

Hi Otto,

It show-up an error on the URL or the application folder name.
I tried both otto-2834023 and otto-2834023.com on URL with no success.

Best,
Lawrence

October 22, 2018 at 2:07 pm #2838344

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello Lawrence,

I am truly sorry.

The folder name is fine, what is wrong is the Destination Site URL, it should be:
hidden link

Let me know if now works, please.

Kind regards,

Otto

October 22, 2018 at 2:48 pm #2838523

ka-lunK

Hi Otto,

Just want to let you know the migration is completed. 🙂
Please have a look.

Best,
Lawrence

October 22, 2018 at 2:57 pm #2838533

ka-lunK

Another update: After the reset & reactivate plugin procedures from: https://wpml.org/forums/topic/database-table-warning/.
Pages other than Home page have no errors now. The error still from Siteground's Memcached. No error found when disabled it.

October 22, 2018 at 4:31 pm #2838980

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Do you mean that if you deactivate the SG optimizer it works fine?

Sadly, the migrated site does not show the errors 🙁

As far as I can see Memcached is enabled, but I must be missing something there. I will check it.

Meanwhile, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

I will install the plugin Query Monitor to do some tests, and also may have to deactivate temporary the SG optimizer plugin. Is this OK for you?

** IMPORTANT **
- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link
 
Kind regards,

Otto