We have just released WPML 4.3.3. Before reporting issues please make sure to update - this version resolves all known issues with the major WPML 4.3 release

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 3 voices.

Last updated by christophe 1 year, 9 months ago.

Assigned support staff: Bobby.

Author Posts
January 11, 2018 at 11:31 am #1481282

ewaldD-2

I see the errors listed as the subject of this ticket when I try to do a manual translation of my home page. I am using Betheme and have my content with the muffin builder. I only get this error with the home page, I can use manual translate for all the other pages fine using the duplicate option under the languages panel on the individual page.

I have contacted betheme who told me to remove and install a new version of the theme, as well as try deactivating all plugins. I have done both and no success.
However I have found out:
If I switch to a different theme and deactivate all other plugins besides WPML multilingual cms, WPML string translation and WPML translation management I still get the same errors for the home page.
With Betheme active, I also noticed that if I deactivate just the wpml translation management plugin, the errors go away and I can duplicate the page but when I visit said page the muffin builder options I have set in the English default page are not there.

January 11, 2018 at 7:41 pm #1482148

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

For the warnings, please try disabling debug mode and let me know if the errors go away.
1. Edit wp-config.php and insert the following lines:

define( 'WP_DEBUG', false );
define( 'WP_DEBUG_LOG', false );
define( 'WP_DEBUG_DISPLAY', false );

This issue is also reported in the past and it was due to hosting server that was using Varnish cache tool, it is same case for your server as well. So you would need to contact your hosting support and see what the can do to solve this. Related tickets are below:
- https://wpml.org/forums/topic/mysqli-errors/
- https://wpml.org/forums/topic/mysqli_real_escape_string-couldnt-fetch/

January 12, 2018 at 11:29 am #1482829

ewaldD-2

I added the lines to the file as you asked, however the errors did not go away. Please see attached screenshot.

I spoke my hosting service and they said:

"The error you were receiving in the WordPress admin panel also appears to
be associated with an error in the site logs coming from the WPML plugin,
for:

[Thu Jan 11 02:51:05 2018] [error] [client 213.225.6.110] FastCGI: server
"/var/run/php-wp_yi8jyi.fcgi" stderr: PHP message: WordPress database
error Column 'post_id' cannot be null for query INSERT INTO
`wp_r2f79x_postmeta` (`post_id`, `meta_key`, `meta_value`) VALUES (NULL,
'_wpml_location_migration_done', '1') made by
require_once('wp-load.php'), require_once('wp-config.php'),
require_once('wp-settings.php'), do_action('init'), WP_Hook->do_action,
WP_Hook->apply_filters, SitePress->ajax_setup,
require('/plugins/sitepress-multilingual-cms/ajax.php'),
do_action('icl_ajx_custom_call'), WP_Hook->do_action,
WP_Hook->apply_filters, TranslationManagement->ajax_calls,
TranslationManagement->make_duplicates,
TranslationManagement->make_duplicate, SitePress->make_duplicate,
WPML_Post_Duplication->make_duplicate,
WPML_Post_Duplication->run_wpml_actions,
WPML_Post_Duplication->duplicate_custom_fields, referer:

"

does this help?

I am in contact with both the hosting service as well as the theme so if I hear anything else I will update. also if it would help I can supply wp and sftp login. please let me know.

thanks for you time.

January 12, 2018 at 5:45 pm #1483309

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

I can take a closer look

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

January 15, 2018 at 6:53 pm #1485120

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

The issue should be resolved now.

I run the troubleshooting actions for WPML within WPML->Support->Troubleshooting and also cleared the WPML cache along with recreating your String Translation Database tables.

January 22, 2018 at 10:21 am #1491717

ewaldD-2

Its fixed thanks so much

March 16, 2018 at 2:27 pm #1548130

christophe

Hi Bobby

Can I ask what actions you exactly ran?

Thanks
Joren