This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Stephanie 1 month, 3 weeks ago.

Assigned support staff: George Botsev.

Author Posts
August 14, 2019 at 3:01 pm #4396241

Stephanie

When trying to make a backup with updraft plus I get a warning that table wp_icl_string_pages has very many rows (906241). My site is also very slow and I'm afraid this might be the reason.

August 15, 2019 at 9:26 am #4399913

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

Hello and thank you for contacting us.

The table icl_string_pages is related to caching mechanism in WPML for strings.
That table will be obsolete and not needed in future releases of WPML, as we did some improvements in WPML String Translation and you can read about them here: https://wpml.org/2019/08/wpml-4-3-beta-1-with-much-faster-string-translation/

I suggest that you exclude the table from the archive of Updraft.
You can follow their guide here on how to do it: hidden link

About the performance of your site - if you wish, you can test the performance of your site with our latest beta.
Please do mind that it is still a beta and it might not be suitable for production environment as we still may have to iron-out some possible issues.
However we are welcoming any feedback that you might have about that version.

I hope that my answer helps you.

August 16, 2019 at 8:07 am #4405359

Stephanie

I have now updated to the beta version, but I still have 997249 tables in the wp_icl_strong_pages. My site is not that big so this is a ridiculous amount. How can I set this right?

August 16, 2019 at 8:28 am #4405425

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

As I suggested above, you should exclude that table from your backup.

We are not removing that table yet - even in the beta, as we are keeping it for backward compatibility.

If you wish, you can truncate the values in it - but please be sure to have a working backup first.

August 16, 2019 at 9:14 am #4405619

Stephanie

Okay, I understand that I could exclude them from the backup.... but the problem is not really in making a backup. The problem is that my backend admin (and front end) are extremely slow. When I disable strings translation it speeds up. And I can't imagine that I should have almost 1 million!!! rows in this table.

August 16, 2019 at 9:28 am #4405687

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

I am sorry that you are experiencing slowness on your site.

We are working on improving the performance.

The table icl_string_pages should not be the source of any performance issue in the latest beta, despite having million rows.

Do you still have the performance issue after testing the beta version?
Perhaps something is wrong and it might be beneficial if you can provide access to your site so that we can try and check it out.

August 16, 2019 at 11:16 am #4405995

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

Thank you!
I visited your site, but currently I am unable to see any significant slowness by just browsing the site.
For me, the site is very fast and responsive.

Could you tell me which pages I need to check so that I don't miss anything there?

*It is possible to test performance of your site on our servers by doing deeper tests with a PHP profiler. If you wish, we can do that too - but we still need to know which pages to test, and of course - your permission to clone your site.

August 16, 2019 at 1:03 pm #4406481

Stephanie

Okay, thanks for checking. I've passed your information on to my client and will see how they react. And otherwise wait until the new version is out and see how things go then. Have a great weekend.

August 16, 2019 at 2:01 pm #4406839

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

Thank you! I will await for your response.

August 19, 2019 at 8:03 am #4414235

Stephanie

I'll wait until the update to see if my problem resolves itself.