If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The currency switcher is not updating the price the client also has an issue with Automatic exchange rates the API is working

Solution: Updating the plugins to the beta version of wpml 4.3-b6 and WCML 4.7-b6 resolved the issue.

This topic contains 15 replies, has 2 voices.

Last updated by Raja Mohammed 2 months, 3 weeks ago.

Assigned support staff: Raja Mohammed.

Author Posts
August 15, 2019 at 6:49 pm

karolinaV

I am trying to:

Change the currency. Multi-currency mode is on, in admin everything looks alright. On the frontend, only the currency symbol is changed, not the amount. Works nicely on localhost, can't find a problem on the development site.

Link to a page where the issue can be seen:
I can share, but privately.

I expected to see:
Currency exchanged or error.

Instead, I got: Just the currency symbol changes.

I've tried to switch to the default theme and no change.
The plugin can't WPML Multilingual can't be uploaded due to an unresolved bug, but it works locally fine). If you temporarily fix it, I'm keen to update, see: https://wordpress.org/support/topic/add-a-custom-service-withou-api-key/

Better to try on duplicator package than online:

August 15, 2019 at 7:36 pm #4403181

karolinaV

UPDATE: It looks like just some products are correctly converted and some not, do you have an idea?
Works: hidden link
Doesn't work:hidden link

August 16, 2019 at 7:37 am #4405251

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I will help you with your issue,

Since you have mentioned that issue only happens on your live site and not on your local and dev site, I could relate the issue to the server cache, Please verify if you have any cache system enable on your live site.

If so try purging them let me know if that helps.

Kind regards
Raja

August 16, 2019 at 10:19 am #4405807

karolinaV

Hi Raja,

I develop (= new website is coming up soon) on with a OP cache turned off and the issue still persists.

Thanks for other troubleshooting.

P.S. If you could, delete the Duplicator package from my message and attach it properly as private message, I haven't found a way to do it after I have created the issue. Thanks a lot.

August 16, 2019 at 1:08 pm #4406493

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I have tested with your duplicator package on my localhost everything works fine. please refer hidden link

I am unable to access your site it seems it is IP restricted. I can still sense this might be an issue with the server cache. To verify whether the issue is with the server i would request you to kindly clone your current setup to one of our private servers. I will send the details about migration in my next private reply.

August 16, 2019 at 1:15 pm
August 18, 2019 at 5:20 pm #4412547

karolinaV

Hi Raja,

thanks a lot. I have migrated the site to cloudwaysapps.com and the problem remains there. Try to click via several products, some of them work nicely (venusiny-kulicky/classic-edition/) and some doesn't (/obchod/vibrator/classic/).

Any help appreciated. I'll be traveling next week, but I think I can answer from my phone if anything needed from my side. I need to have it working by 26th.

Thanks a lot!
Karolina

August 19, 2019 at 5:24 am #4413573

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Karolina,

I tried with several products on the clone site everything seems to be working fine, Please refer my screencast hidden link

Please check the clone site on a new browser check if you can reproduce the issue.

I see that you are using Loco Translate along with WPML String translation which is not advisable, though it might not be related to the issue it can have some effects on the front end display.

Regards
Raja

August 22, 2019 at 6:53 am #4436937

karolinaV

Hi,
as you can see even on your first screencast product, it's not working. 750 Kc is not equal to $750. The CZK price needs to be converted, however, here is only the symbol moved to front of the price and the currency conversion doesn't happen. If you look in the administration and check the price in the product details, you will see the correct one.

In the case of some products, it works fine, but not for the others. See my examples above anch check for the currency and correct conversion.

Thanks a lot

August 22, 2019 at 12:33 pm #4439263

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks for the clarification,

I have checked this further in the clone site, Updating the WooCommerce Multilingual plugin to the latest version 4.6.5 resolved the issue.

hidden link

It seems you are using an older version of WooCommerce Multilingual plugin 4.4.2.1, Secure a backup of your site and database before updating to the latest version of WooCommerce Multilingual 4.6.5.

I hope this resolves your issue.

Kind regards
Raja

August 23, 2019 at 9:55 am #4445757

karolinaV

Ok, sounds like its possible where can I check it?

The problem is that the latest version has a bug within the currency exchange classes, see the wordpress.org issue related above. That leads to a distinction of a custom exchange service WITHOUT the API key. Could you have a look and provide me a fix until you merge it into the plugin? That was the only reason making me to stick with the old version.

Best regards,
Karolina

August 23, 2019 at 10:30 am #4445919

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I think the issue with the automatic exchange is already fixed with the latest version. May be you can check in the clone site. Try enabling the Automatic exchange rates and add the appropriate service API in WooCommerce multilingual settings

You can log in to the clone site here hidden link
with the same details which you have shared earlier while creating this forum ticket.

let me know how it goes.

Kind regards
Raja

August 23, 2019 at 10:40 am #4445931

karolinaV

H8, it wasn't fixed in 4.6 5, have a look at the forum (sorry for the rely, but I am ooo.

K.

August 23, 2019 at 11:29 am #4446363

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I'm extremely sorry about the miscommunication.

I just checked with the developer the issue is already fixed and available in our next WCML release.

The fix is also available in our latest beta release, I have updated the clone site to the beta release, maybe you can check now.

In case if you need FTP details for the clone site you have it already from my previous response https://wpml.org/forums/topic/wc-multicurrency-currency-switched-but-price-not-updated/#post-4406559

In case if you consider updating to the latest beta release please refer to the instructions https://wpml.org/faq/how-to-install-beta-and-development-versions-of-wpml/

Let me know how it goes.

August 27, 2019 at 4:43 pm #4468549

karolinaV

Hi, that looks good, however, maybe I'm doing something wrong, but when I try to update to beta versions, the installation starts and all website is down because of an error. Could you have a look on my install and fix it?