Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Andreas W. 2 months, 2 weeks ago.

Assigned support staff: Andreas W..

Author Posts
September 17, 2021 at 4:12 am

mikeC-25

Taking a site copy for testing and debug.

September 17, 2021 at 4:57 am
September 18, 2021 at 2:18 am #9611227

Andreas W.
Supporter

Languages: German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I was right now having a look at the copy which I took from your website:

The issue on the product archive pages disappears once we disable "WooCommerce Product Search".

The issue persist if the site runs only with:
- Twenty Twenty One Theme
- WooCommerce
- WooCommerce Product Search
- WPML and our Add-ons

The issue disappears once I disable the option WooCommerce -> Settings -> Search _> General Settings -> Standard Product Search -> Optimize front end product searches.

I would suggest you disable this option for now and you should see that the product archive pages work as expected.

The WooCommerce Product Search Plugins appear not to be part of our compatibility list yet, which means that we did not get the chance yet to test it WPML.

https://wpml.org/plugin/?wpv_view_count=120064&wpv-plugin-functionality=0&wpv_post_search=Product+Search&wpv-wpcf-recommendation-flag=&wpv_filter_submit=Search

It would be great if we could get your support on this matter. Would it be possible for you to install the plugin on the following test site so that I can test, if we can recreate the issue and escalate it to our compatibility team, please?

If so, please let me know and I will provide a test site for you.

Best regards
Andreas

September 18, 2021 at 6:56 am #9611835

mikeC-25

Yes, please let me know the test site details, I will install the plugin.

September 18, 2021 at 7:01 pm #9612989

Andreas W.
Supporter

Languages: German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I have created a temporary test site. Take note that this site will get deleted automatically after it does not receive any request within seven consecutive days.

Please install the plugin here:

One-Click-Login:
hidden link

Leave me a short notification once the plugin is installed, please.

Best regards
Andreas

September 18, 2021 at 7:43 pm #9613081

mikeC-25

I am inside the staging website right now.
Which plugin do you need me to install on it?

September 18, 2021 at 8:01 pm #9613089

Andreas W.
Supporter

Languages: German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Please only install "WooCommerce Product Search" in its latest available version.

Please do not upload an already used version of the plugin folder from another website.

We do need to make sure if the issue persists with the latest and freshly installed version that ships out by WooCommerce in order to be able to reach out to them in case there is an issue between their plugin and WPML.

Best regards
Andreas

September 18, 2021 at 8:16 pm #9613095

mikeC-25

I can not find my zip for this plugin. I recently clicked Update button for each of my products. The translated categories now does display products, instead of showing 0 products.

So even after I clicked disable, I am not able to re-produce the problem.
Right now, I am adding a few new products, and I will see if my translated categories show or do not show any products.

Regarding uploading plugin to that staging site, in order to work with the plugin author to make it working with WPML, I will not go ahead. If the issue is that plugin, I will just delete it, there are many WPML compatible alternatives as your previous URL shows.

By the way, which staging hosting are you using?
It seems fast.

September 18, 2021 at 8:50 pm #9613167

Andreas W.
Supporter

Languages: German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message. Indeed, there might be an alternative you could use here but if updating the plugin solved the issue for now, then this means that this was already solved in their latest update.

The test site:
What we are using here is a sandbox that we have set up only for testing purposes. The sites get deleted after 7 days without any requests.

To be honest, I am not sure where this is currently hosted, but it might be AWS.

Let me know if you need any further assistance regarding the reported issue.

Best regards
Andreas