Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: Trying to translate Store URLs from the WooCommerce -> WooCommerce Multilingual -> Store URLs tab does not work. No dialog is shown and there is a javascript error in the console: Uncaught ReferenceError: _ is not defined

Solution: This is due to a dependancy not being loaded (Underscore.js) and is fixed in the WCML v4.7.0-RC1 update, available from WPML.org -> Account -> Downloads -> Beta Channel

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by per-egilR 11 months, 1 week ago.

Assigned support staff: Izzi Hassan.

Author Posts
October 16, 2019 at 8:27 pm #4768451

per-egilR

I am trying to: Add / edit store URLs here: WooCommerce >> WooCommerce Multilingual >> Tab "Store URLs"

I expected to see: A translation dialog when clicking on the pencil (Edit translations) or plus sign (Add translations).

Instead, I got: Nothing, the page freezes and I get a JS error in the Crome Console: "Uncaught ReferenceError: _ is not defined"

October 17, 2019 at 8:54 am #4771347

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for reaching out to WPML Support.

This appears to be related to an issue we are aware of. In order to confirm this and provide you with a solution, I would like to request temporary access to your development site's WP Admin.

Request for temporary access

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures
I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to back up the site before providing us access. If we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy
We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

IMPORTANT
Please make a backup of site files and database before providing us access.

If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC.

DO NOT post your website details unless you see the required wp-admin/FTP fields.

If you do not, please ask me to enable the private box.

The private box looks like this:
hidden link

October 17, 2019 at 9:49 am #4771715

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I cannot recreate this issue.

If you are still seeing this error and no dialog box, can you provide some steps to reproduce it? I have tried clicking on the "Add Translation" and "Edit Translation" buttons but the dialog appears just fine.

October 17, 2019 at 10:05 am #4772129

per-egilR

Hello Izzi,

Yes, I'm still having the issue. I have tested with the latest version of Google Crome and Microsoft Edge.

Steps to reproduce:

1. Open hidden link with Crome or Edge.
2. Click on the pencil or plus sign below the German flag.
3. No dialog is displayed and the page freezes (you can't scroll).

Both the Crome and Edge JS console reports the error.

October 17, 2019 at 10:09 am #4772195

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I am not seeing the same thing you are as shown in the screenshot attached.

This issue is caused by a missing javascript dependency and was resolved in the version of WCML you are currently using. I would recommend clearing your browser cache as a first step to see if that solves your problem.

Please try clearing caches and let us know if you still see the console error.

October 17, 2019 at 10:25 am #4772435

per-egilR

Hi Izzi,

I have cleared the cache and shift-reloaded the page with Crome DevTools "Disable cache" checked. Still the same error.

October 17, 2019 at 10:25 am #4772437

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

My team has just informed me that this issue is resolved in a new version of WCML available in the Beta Channel on the Downloads section of your wpml.org account:
https://wpml.org/account/downloads/

Please download WCML 4.7.0 RC1 and update the plugin. This should resolve your issue reliably.

October 17, 2019 at 10:40 am #4772573

per-egilR

Hi Izzi, updating to WPML 4.3 RC1 resolved the issue.

Thanks
Per