Due to the large volume of support requests, at the moment there is a waiting time of more than 24 hours. We apologize for the inconvenience this causes. We do not have any recurring unknown issues so we encourage you to please search the forum for other support topics that might be helpful and to review our documentation and look at our errata page for known issues. We are all working hard to go back to the normal, a supporter will respond to you as soon as possible.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Admin bar not showing on the secondary languages when the option "languages on different domains" is enabled.

Solution: This is actually how WPML is expected to work when the option "languages on different domains" is used. The admin bar is only visible on the default language.

Tagged: 

This topic contains 2 replies, has 2 voices.

Last updated by merijnK 2 years, 7 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
April 4, 2016 at 12:45 pm #852522

merijnK

I am trying to: View the admin bar on the front end of the translated version of the site

URL of (my) website where problem appears:

hidden link
hidden link [translated version of the site]

I expected to see:

A admin bar

Instead, I got:

No admin bar

Steps to duplicate the issue:

1. Log in on the site
2. Go to hidden link
3. You will see the admin bar at the top of the site.
4. Go to the German version of the site hidden link
5. You will see no admin bar

Can you help me with this?
I suspect it has to do with the subdomains.

Thanks in advance.

April 5, 2016 at 10:09 am #853463

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hey there,

This is actually how WPML is expected to work when languages on different domains is used. The admin bar is only visible on the default language.

Sorry for any inconvenience this causes.

Thanks

April 5, 2016 at 9:57 pm #854137

merijnK

Okay thanks