Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The user was having duplicated fields in the Translation Editor. Solution: This was due to an inconsistency in the database. The issue came from an empty field in a serialized array saved on the "icl_sitepress_settings" option key in wp_options table. As you can see in the attached image to my private reply. The empty key should not be so, we need to patch it by replacing the empty key, with the value "test".

This topic contains 17 replies, has 2 voices.

Last updated by alexD-12 3 months, 1 week ago.

Assigned support staff: Jamal.

Author Posts
August 7, 2019 at 9:54 am

alexD-12

I am trying to:

We have a lot of custom field, with wery big content, i think are fields from elementor.
If i try to open the translation manager i receive a timeout error.
I try to : Optimize db, disable all theme and plugin, search one option to disable custom fields.

Link to a page where the issue can be seen:
you need to access to backoffice
i already duplicated the site on the link i provided

I expected to see:
translation page without all these custom fields

Instead, I got:
timeout error

August 7, 2019 at 3:37 pm #4356543

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for contacting WPML Support. I will be glad to help with this.

Can you please activate PHP debugging and check if any errors are logged in it.
1. Please follow the debugging information provided here: http://wpml.org/documentation/support/debugging-wpml/
2. Repeat the action of creating the problem.
3. Share the debug.log (log file inside the /wp-content/ directory) here or using DropBox or GoogleDrive.

Can you also point me to a specific translation where I can see this issue?

Looking forward to your reply.

Best regards,
Jamal
WPML Support

August 8, 2019 at 6:56 am #4360165

alexD-12

Hello,

I try to explain the problem better.
Performing a translation with the manager the first time works.
If the page is changed in the main language or if the translation is not complete, the gear appears in the list of pages, as it should be.
However, if I click the gear for the page it is not loaded with a gateway error (this on siteground).
Now I have installed a copy of the site on another more powerful server and here after 2/3 minutes the page of the translation manager opens.

It's possible disable custom fields from translation manager ?

As you can see in the attachment, for example, field-20 is huge. And in my opinion it is the cause of the server overload.

We use this plugin on the site
Ultimate Addons for Elementor
I noticed that if this plugin is installed and deactivated wpml the site crashes completely, since I need to remove the plugin from ftp and then the site works again.

No errors appeared in debug.log

August 8, 2019 at 7:01 am #4360217

alexD-12

You can se the problem on all pages with the gear icons.
As example Berries Food Ingredients.

August 8, 2019 at 11:09 am #4362173

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Indeed, I tried the page "Berries Food Ingredients", the translation was opened in 209s.
To deactivate custom fields, you can create an XML configuration like expressed in this article
https://wpml.org/documentation/support/language-configuration-files/#custom-fields

But I would like to reproduce this issue on a clean install, If you can reproduce this issue with your theme and Elementor plugins in this server hidden link
I'll be happy to escalate it to our developers.

Can you also try with a new page with minimal content, and check if the fields field-(number) are added to the translation editor.

Best regards,
Jamal

August 8, 2019 at 11:52 am #4362351

alexD-12

Hello Jamal,
thanks for your answer.

I put this code in the wpml xml page

<wpml-config>
    <custom-fields>
        <custom-field action="ignore">field-*</custom-field>
    </custom-fields>
</wpml-config>

But no one is ignored. I try without the wildcard... mirate field-20 but nothing.
Where am I wrong?

We have 4 other identical sites as plugins and theme configurations.
We looked for differences in each configuration setting but found nothing.
They are all on the same hosting.
I don't even think we can recreate this problem very easily.
We probably played with the settings of the translations, of the custom fields. But we often do it to translate some elementor modules.

Thanks

August 8, 2019 at 12:59 pm #4363111

alexD-12

Hello,

A new page also has the filed- (number) but goes up to 5, adding elements to the page increases the number of fields

August 8, 2019 at 2:20 pm #4363767

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for your feedback. I see. Can you allow me access to the database interface, I'd like to understand from where came the field-*. If not possible, can I install the WP phpMyAdmin plugin to browse the database from the WordPress backend?
Otherwise, allow me to take a Duplicator copy of your website and check locally.

Best regards,
Jamal

August 8, 2019 at 2:32 pm #4363855

alexD-12

I have installed WP phpMyAdmin plugin.

August 8, 2019 at 4:52 pm #4364823

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

checking the database, it seems that the content of field-20 is equal to the content of _elementor_data field in the postmeta table.

When trying again to load translation, they were loading normally(10s), I tried with serveral pages, I suspect that the issue was also because of server resources, especially database, maybe because of the traffic on the website the database was overloaded and that causes this issue.

Anyway, I am approaching our 2nd Tier team for hints or tips on how to remove the field-(number) from the translation editor.

I'll get back to you as soon as possible.

Best regards,
Jamal

August 9, 2019 at 8:32 am
August 9, 2019 at 8:56 am #4368823

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

We have found a data inconsistency in a WPML option, I patched it and left a backup of its value in my last private reply.

This solution resolved the issue for new pages. Check my test (page WPML Test).

For existing pages that represent the issue, you will need to resend those pages to translation through WPML->Translation Management. I tested it with pages that have title "Natural Food Ingredients". To be able to do that, I added my user as a translator in WPML->Translation Management->Translation Roles.

Please check this workaround(resending pages to translation) for other pages an let me know if it is viable for you.

Best regards,
Jamal

August 9, 2019 at 9:04 am #4368863

alexD-12

Hello Jamal,

ok i try on the production server.

August 9, 2019 at 9:13 am #4368893

alexD-12

How can i patch my production site ?

August 9, 2019 at 9:54 am #4369253

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Sure. The issue came from an empty field in a serialized array saved on the "icl_sitepress_settings" option key in wp_options table. As you can see in the attached image to my private reply. The empty key should not be so, I patched it by replacing the empty key, with the value "test". It is a little hard to patch a serialized array. Please allow me temporary access to your production site to fix it. Or share the value of the "icl_sitepress_settings" option and let me correct and share it with you.
Then, you will need to resend pages to translation.

The private box is activated to privately share the value of the key or access data.

Best regards,
Jamal