This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 4 replies, has 2 voices.

Last updated by Raja Mohammed 5 months ago.

Assigned support staff: Raja Mohammed.

Author Posts
May 16, 2019 at 11:02 am #3825171

abinJ

Tell us what you are trying to do?
hidden link The Above url is redirecting to the taxonomy page
Is there any documentation that you are following?
No
Is there a similar example that we can see?

What is the link to your site?
hidden link

May 16, 2019 at 12:53 pm #3825989

abinJ

Tell us what you are trying to do?
hidden link The Above url is redirecting to the taxonomy page
Is there any documentation that you are following?
No
Is there a similar example that we can see?

What is the link to your site?
hidden link

May 16, 2019 at 1:58 pm #3826597

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Please provide us with more information,

How to reach the page with our directly accessing the supplied url,
It seems more like a filter query, But however, in yoursite, all the filtering is done through an ajax calls,
I'm not sure how to reproduce the issue here, Maybe a step by step process that we can follow in your site will help us better.

Kind regards
Raja

May 17, 2019 at 4:45 am #3831403

abinJ

The issue persists in both cases in all the language except the default English language . When we run the URL directly it is redirecting to the taxonomy page or when we pass the URL through ajax filter it fetches taxonomy data.

You can reproduce the issue using the following steps.

1)Click on the below URL
hidden link

2)Select a color from the filter
3)Select a brand from the filter

Now you can see the issue.

May 17, 2019 at 7:09 am #3831703

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Please confirm whether the language filter for Ajax is enabled,
WPML > Languages > Language filtering for AJAX operations, Enable/check the option
"Store a language cookie to support language filtering for AJAX"

Clear the cache and check the results, let me know if this helps.

Kind regards
Raja