This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by rodrigog-13 2 weeks, 5 days ago.

Assigned support staff: Noman.

Author Posts
September 19, 2019 at 8:00 pm #4608189

rodrigog-13

I am trying to: install and activate WPML and additional plugins. Once I activate String Translation I get error

Link to a page where the issue can be seen:

I expected to see:

Instead, I got

September 22, 2019 at 9:06 am #4617797

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support.

=== Please backup your database and website ===

It seems you have just installed WPML plugins and configuring WPML first time on this site and do not have any translated data yet. So you can fix this issue by removing WPML and all its data completely from database.
To do so:
1. Please go to WPML >> Support >> Troubleshooting (the link is at the bottom of the support page). >> There, click on “Reset and deactivate WPML” >> then Delete the plugin.

OR

- If you face any issue in accessing WPML >> Support >> Troubleshooting page then please go to *_options database table and delete the ‘icl_sitepress_settings’ entry. This caused WPML to start over with set up.

2. After deleting all WPML data and WPML related plugins then please install WPML plugins again and I hope now you will not face any issue.

This issue usually happens due to some corruption in the database, if you are installing WPML first time in this site and you see some database tables starting with <srtong>icl_</srtong> even after reset, please also delete those tables and try reinstalling WPML.

Here is doc for more details:
https://wpml.org/faq/how-wpml-reset-works/

3. If still issue persists, please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Seventeen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

Thank you

September 25, 2019 at 1:27 am #4634647

rodrigog-13

My issue is resolved now. Thank you!