This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Mihai Apetrei 1 year, 8 months ago.

Assigned support staff: Mihai Apetrei.

Author Posts
October 3, 2018 at 12:38 pm #2784515


Hi there,
we have German as our main language and in google search results the right URL will come up, however, the wrong meta description is showing (in English). we have tried everything incl. hiring SEO experts. Nothing is working, yet. So assuming this may be a WPML issue.
Thank you! - hidden link

October 3, 2018 at 3:25 pm #2785059

Mihai Apetrei

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

This might happen due to browser language redirect.

As of 2015, Google understands the browser language redirection and will interpret it as a redirect to another URL so if you see the ‘wrong’ languages in Google index, consider disabling the browser language redirection.

This causes the Google bot to be redirected to EN whenever it is crawling your site's page. So practically it starts reading the page in German and then it is redirected to the English content so it receives mixed meta information.

Please go to WPML > Languages > and under the "Browser language redirect" section, make sure that the "Disable browser language redirect" option is used.

If that's set right, please make sure there's no other language redirect coming from another plugin as I can see by visiting your site from an incognito window that there's a redirect to the English language whenever I visit your main site page that should be German by default (my browser is in English).

There is more info about this here: