If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 25 replies, has 3 voices.

Last updated by Bigul 2 months, 3 weeks ago.

Assigned support staff: Bigul.

Author Posts
August 17, 2019 at 8:16 am #4409575
XIAO XIA

ok. i got your response
and did it according to your request

hope the problem will be solved soon.

by the way, it notice "Some taxonomy terms are out of sync between languages. This means that content in some languages will not have the correct tags or categories.

In order to synchronize the taxonomies, you need to go over each of them from the following list and click the "Update taxonomy hierarchy" button."

should i do something?

New threads created by Bigul and linked to this one are listed below:

https://wpml.org/forums/topic/some-taxonomy-terms-are-out-of-sync-between-languages-3/

August 17, 2019 at 8:18 am #4409579

XIAO XIA

by the way, please delete our web site address which i listed in the first question page.
i can't modify it now

August 17, 2019 at 10:04 am #4409787

XIAO XIA

one more question
i see two different page for the other languages pages.
for example, IN MY web site it is hidden link
but google indexed my site and use it as hidden link
so i think there's somewhere i setted wrongly,
could you please check it for me?
thanks

August 17, 2019 at 3:38 pm #4410361

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I have opened a new ticket for the taxonomy terms sync issue. Because as per our support policies, we can only handle one issue per ticket. It will help us to serve you better and we can avoid discussing multiple problems in one ticket. I will get back to you soon on the new ticket. Please wait. Thank you for your understanding.

Please note, the URL of this ticket will be only visible to you and our forum moderators.

I will check about the Spanish Homepage URL issue with our team and get back to you soon. Please wait.

--
Thanks!

Bigul

August 18, 2019 at 1:40 pm #4412301

XIAO XIA

i see two different page for the other languages pages.
for example, IN MY web site it is hidden link
but google indexed my site and use it as hidden link
so i think there's somewhere i setted wrongly,
could you please check it for me?
thanks

August 19, 2019 at 4:43 pm #4417507

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I am checking the *Spanish Homepage URL* issue with our team now. Will get back to you soon. Please wait.

--
Thanks!

Bigul

August 20, 2019 at 3:35 pm #4425091

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

It is happening because the canonical URL is set without trailing slash. Please check the attached image.

<link rel="canonical" href="hidden link" />

Please add the following code in fuctions.php of your theme after a site backup and make sure you are getting the expected result or not.

add_filter( 'wpseo_canonical', 'trailingslashit', 20 );

Please check the following Errata URL for more details and let me know your feedback.

https://wpml.org/errata/changes-in-the-way-wpml-handles-the-trailing-slashes-in-url-conversion/

--
Thanks!

Bigul

August 22, 2019 at 4:22 am #4436233

XIAO XIA

i had added this code to functions.php
but the problem still not solved.
why?

August 22, 2019 at 3:45 pm #4440929

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. It requires further checking. Please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

August 26, 2019 at 2:38 am #4455593

XIAO XIA

ok

August 26, 2019 at 12:30 pm #4458475

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for your permission. Somehow the Duplicator filtering not working on your site now and the Package size is huge. So I will try after a gap and get back to you soon. Please wait.

--
Thanks!

Bigul

The topic ‘[Closed] we have got many duplicate posts in different language’ is closed to new replies.