Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem:We want to show a hidden language but not saving, giving "Error: data not saved

Solution:We´ve found the culprit. Its a security plug-in that changes the backoffice url path, so the AJAX url wasn´t finding the php file. Deactivated this functionality to save the WPML setting and all good now.

Relevant Documentation:

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by sandraM-10 3 years, 8 months ago.

Assigned support staff: Bobby.

Author Posts
April 26, 2017 at 4:46 pm #1262574

sandraM-10

I am trying to: un-hide a hidden language but i cant save the setting it replyes "Error: data not saved"

We are using latest versions of wordpress and plugin.

Regards, thanks.

April 26, 2017 at 9:48 pm #1262762

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

As a quick compatibility test please test this:
-Back up your site first
-Deactivate all non WPML related plugins
-Switch for a moment to a WordPress default theme like Twenty Fourteen.
-If the issue is gone, activate one by one to see with wich one there is an interaction issue

Let me know your results please.

Kind Regards,
Bobby

April 27, 2017 at 9:01 am #1263043

sandraM-10

Hi,
We´ve found the culprit. Its a security plug-in that changes the backoffice url path, so the AJAX url wasn´t finding the php file. Deactivated this functionality to save the WPML setting and all good now.

Thanks