This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Vincenzo 1 year ago.

Assigned support staff: Vincenzo.

Author Posts
October 1, 2018 at 10:04 am

alexanderv-30

Hi, I have turned on the option that website loads on different languages automatically based on the visitor's browser language.

At this moment we have Dutch and German translation, but our visitors from The Netherlands and Germany always get the English version when they come to our homepage.

hidden link

October 2, 2018 at 4:38 pm #2782272

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello, thank you for contacting WPML Support!

I just tested your website and the automatic redirect works correctly.

These are the steps I used to test the website:
- Open a browser in private/incognito mode
- Open the browser settings
- Go to the language settings
- Add the Dutch and German languages
- Move the Dutch language to the top (see screenshot)
- Type the address of the site in the URL bar
- Check that the redirect works correctly.
- Close the browser
- Repeat the steps above for the German language

Please let me know if this solves the issue or if you need further details.

Thank you