Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 3 voices.

Last updated by Noman 3 years, 10 months ago.

Assigned support staff: Noman.

Author Posts
March 26, 2017 at 2:15 am #1239580

attiahA

Hello
i have a website in English and Arabic language

my website Default language is Arabic

i want my admin language in English and not translate any word to Arabic

Website === Arabic
Admin ==== English

how i can do this ...

March 27, 2017 at 3:50 pm #1240501

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Attiah,

Thank you for contacting WPML Support. We have couple of options for this:

1. You can use WPML Language Switchers in WordPress Admin screen (at the top left) to switch to English language. Also you can change language from your WordPress User Profile page:
Example: hidden link

2. Alternatively, you can use this plugin to have English WordPress Admin:
https://wordpress.org/plugins/english-wp-admin/

More details: hidden link

Thank you

March 27, 2017 at 10:15 pm #1240752

attiahA

Hello
i try all your suggisions but no any solution work with me

also i read this article
hidden link

not work

how can i solve this problem ???

March 28, 2017 at 5:44 pm #1241703

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hello Attiah,

I have tried some things to set it up as your requirements are. I do not have the same setup as you have but please see the video below that shows Language Settings and behavior that is appear to be working nice for me and I am always getting Admin backend in English regardless of website’s frontend language:
hidden link

- The most important thing here is that Editing language is “Unchecked” under WP Dashboard >> Users >> Your Profile >> WPML language settings >> Editing language (deselect this option and click Update Profile). Both these options I have also shown in the above video.

- I have my Default Language setup as English which might be different from your case.

Thank you

March 28, 2017 at 6:31 pm #1241721

attiahA

My Case is completely different

my website main page is Arabic

how can i set my admin in all cases and languages in English

this is my direct request

March 30, 2017 at 4:20 pm #1243616

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hello Attiah,

Sorry for some delay, I was on holiday and my tickets queue is overloaded. I will be processing your request but it may take bit more time than usual.

I would need to request temporary access (WP-Admin & FTP) to your site so I can see your setup – preferably to a test site where the problem has been replicated if possible –
in order to be of better help and check if some configurations might need to be changed.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

April 3, 2017 at 6:03 pm #1246150

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Attiah,

Hope you are doing great. Thank you for sharing login details. Yes sure, I will note down all the changes I perform on your site I am going to work on it and get back to you soon.

Thank you

April 4, 2017 at 9:02 pm #1247303

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hello Attiah,

Thank you for waiting on this, I have made numerous changes and now your WP Admin is always in English (screenshot attached). Please see the list of changes I have made below:

1. Deactivated plugin: English WordPress Admin
2. Removed (comment out) this from wp-config.php file: define ('WPLANG', 'en');
3. Duplicator Manual Backup created: 2017-04-04 22:04
4. Deleted en_GB .po/mo files from: /home/cgway/public_html/wp-content/languages (actually there is no need to load Enlgish files). I have saved these in same folder as en_GB.zip.
5. Changed an option in WPML >> Theme and plugins localization >> see attached screenshot.
6. In WP Settings >> General >> I have changed english Site Title only to "Graphic Academy", you can change it in Arabic language as well.

Have a great day,
Thank you

1. Dashboard in English.png
2. Theme and plugins localization.png
May 16, 2017 at 1:46 pm #1277295

attiahA

Hello
i face a many problems with WPML
the user menu in English take the Arabic translation
and some translation went the page load shown fine and after the page completely load the strings changed to the other language something crazy

i record this video
hidden link

May 16, 2017 at 2:57 pm #1277399

attiahA

i try to deactivate all plugins one by one and the problem not solved .
i confirm the problems comes from the WPML or any setting modified by WPML Support in my website

May 17, 2017 at 10:43 am #1278051

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Attiah,

I have taken a look at the video and I understand your concern about the string translation problem. This issue is separate than the original issue we resolved previously in this ticket.

So please kindly open a new ticket for this issue. We handle one issue per ticket. This will help other users with similar problems to find solutions when searching the forum.

Thank you

May 18, 2017 at 7:58 am #1278846

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello @attiaha

Please don't post a single query on multiple threads! https://wpml.org/forums/topic/admin-language-problem-and-buddypress-with-wpml/page/2/#post-1277293

I understand you need a fast solution! But this will make things more complex to solve the issue.
The recommended approach is
#1 please provide the feedback and close the ticket once issue is resolved.
#2 One thread per issue!

Thanks for your cooperation!

Thanks

September 10, 2017 at 10:42 pm #1366705

attiahA

Hello
after update to WPML Multilingual CMS 3.8.0
the main problem comes again

how we can solve it again

September 11, 2017 at 9:23 am #1367061

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Please kindly open a new ticket for this issue, which could be related to updates, so that our support team can reply. This will help other users with similar problems to find solutions when searching the forum.

Thank you

P.S. I am not working on WPML support these days, working on our other product Toolset.

The topic ‘[Closed] Website and admin in different languages’ is closed to new replies.