This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Andreas W. 5 months, 1 week ago.

Assigned support staff: Andreas W..

Author Posts
May 14, 2019 at 8:19 pm

dominicH-2

I am trying to: Use the updated String translation plugin as usual

Link to a page where the issue can be seen: hidden link

I expected to see: No errors

Instead, I got:

Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 20480 bytes) in /srv/users/serverpilot/apps/deliawang/public/wp-content/plugins/wpml-string-translation/classes/filters/db-cache/class-wpml-st-db-translation-retrieve.php on line 181

Hi, I'm running an updated website using WPML CMS and string translation and I just updated to the latest version of both today. After updating, when I click on the language switcher in the menu to see translated pages in Mandarin, I get an error message on each pages mentioning the memory size is exhausted.

I tried deactivating the String translation plugin and it solves the issue, but I now reactivated it on the site so you can see it. The issue is indeed coming from the String translation plugin

I also made sure to add the following in my wp-config.php:

define('WP_MEMORY_LIMIT', '256M');
define('WP_MAX_MEMORY_LIMIT', '256M' );

Can you please help with this?

May 14, 2019 at 8:35 pm #3810567

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting WPML Support.

Could you please increase your PHP Memory Limit inside of the php.ini file for PHP version 7.1.29 to 1024M. Afterwards, change the WP Memory limit to 512M inside of the wp-config.php file. It is always recommended to run a higher value for the PHP Memory Limit than for the WP Memory Limit and it seems the current WP Memory Limit is not high enough to run the site.

Your current values are:

MemoryLimit 256M
WP Memory Limit 256M
Add this code to your wp-config.php to increase WP memory:

/* Memory Limit /
define('WP_MEMORY_LIMIT', '512M');

Paste it just before:

/ That's all, stop editing! Happy blogging. /

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly.
If you can get even higher values It would be great.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means, with a default theme and not other plugins installed.

Let me know if this solved the issue.

Kind regards
Andreas

May 14, 2019 at 9:22 pm #3810741

dominicH-2

Hi Andreas,

Thanks for your answer.

I just did the php & WP memory increase and the issue still persists. Regardless, I can increase the limit, but the issue really started just now when I updated the plugins. Before that, the site and translations would work flawlessly and would not even get close to hitting the memory limit (which was set to its default value of 40MB).

In my opinion, there is clearly an issue with this update and increasing the memory limit would simply hide this issue instead of resolving it.

Is it possible to take a look?

May 14, 2019 at 9:40 pm #3810813

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Yes, sure. But before that please try the following:

1. Go to Dashboard → Updates;
2. Press the Check Again button;
3. Press the Update button at the bottom of the page (Compatibility);
4. Go to Plugins → Add New → Commercial; install again

If this will not so0lve the issue I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

The topic ‘[Closed] Website crash after updating String translation due to memory limit’ is closed to new replies.