This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by kutbetting 2 months, 3 weeks ago.

Assigned support staff: Mihai Apetrei.

Author Posts
July 15, 2019 at 9:07 am #4208701

kutbetting

Tell us what you are trying to do?

ALL I TRY to TRANSLATE THE SİTE

Is there any documentation that you are following?

WPML
Is there a similar example that we can see?
YES MY WEB SİTE GIVE ERROR 404
What is the link to your site?
hidden link

July 15, 2019 at 9:13 am #4208815

kutbetting

i need help . how long do i need wait ?

July 15, 2019 at 10:12 am #4209597

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

I am sorry to hear that you are having trouble with our plugin.

Can you please help me understand a few things better?

I can see the 404 error happening here:
hidden link

Can you please try the following steps:

- disable all plugins except WPML and its add-ons
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again so that you can understand which plugin is causing that issue

If the issue happens even with the non-WPML plugins disabled:

- leave all the non-WPML plugins deactivated
- switch to a default theme like TwentySeventeen
- try to recreate the issue now

If the issue is still happening, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

In order to be able to help you faster, can you also please paste your WPML Debug information in the Debug information field?
http://wpml.org/faq/provide-debug-information-faster-support/

I will be waiting for your response.

PS: Regarding faster help, in case you don't want to wait for getting an answer in a ticket, you can mark this current ticket as resolved and then, in the process of creating a new ticket, select that you want LIVE CHAT instead of a ticket.

Kind regards,
Mihai Apetrei

July 16, 2019 at 3:20 pm #4221679

kutbetting

any news ?

July 16, 2019 at 3:27 pm #4221743

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

1. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased as the minimum requirement for WPML is 128Mb WP Memory Limit: https://wpml.org/home/minimum-requirements/

❌ Very important: please make a backup of your site (files & database) before following any of the upcoming steps ❌

Please add this to your wp-config.php file to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Paste it just before:

/* That's all, stop editing! Happy blogging. */

These settings can be limited directly by your hosting provider, so, if that’s the case, I recommend you to contact and ask them to modify them directly. If you can get even higher values It would be great.

Please make sure you have updated the values successfully, You can verify them from WPML >> Support page.

2. Regarding this "i had 404 error but now i have 503 error when i change the setting.":

- Can you please let me know what setting are you referring to that you changed and where do you see the error?

3. Regarding the second issue where you get the "500 internal server error", that usually happens due to low server resources or due to plugins/themes conflicting with WPML.

Can you please try this and see if you are still receiving the 500 error:

- disable all plugins except WPML and its add-ons
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again so that you can understand which plugin is causing that issue

If the issue happens even with the non-WPML plugins disabled:

- leave all the non-WPML plugins deactivated
- switch to a default theme like TwentySeventeen
- try to recreate the issue now

Please let me know how that goes and what you will be able to find by following the steps above.

I will be waiting for your response.

Kind regards,
Mihai Apetrei

July 16, 2019 at 4:39 pm #4222417

kutbetting

hi
i just did this
Please add this to your wp-config.php file to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

my site admin doesnt work

when i click upgrade or anything else give error 503

AND WPML needs to set languages to existing media in your site. When i try to set media language give this error

This request takes too long to process, it is timed out by the server. If it should not be timed out, please contact the administrator of this web site to increase 'Connection Timeout'.

July 17, 2019 at 6:54 am #4226219

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for your response.

All of these issues sound to me like they are happening due to limited hosting server resources.

Also, from what I can see, the WP memory limit is still 40MB in the backend so it might be limited by the hosting provider.

1. Can you please provide FTP access in the private fields I am enabling below?

2. Also, can you please let me know if you tried the steps below and if you've seen different results:

- disable all plugins except WPML and its add-ons
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again so that you can understand which plugin is causing that issue

If the issue happens even with the non-WPML plugins disabled:

- leave all the non-WPML plugins deactivated
- switch to a default theme like TwentySeventeen
- try to recreate the issue now

Please let me know.

I will be waiting for your response.

Kind regards,
Mihai Apetrei

July 25, 2019 at 12:35 pm #4283093

kutbetting

My issue is resolved now. Thank you!