This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Please make sure to update to WPML to the latest and check our list of Known Issues before reporting

This topic contains 10 replies, has 2 voices.

Last updated by fabioA 6 years ago.

Assigned support staff: Andreas Neuber.

Author Posts
January 28, 2014 at 8:35 am #328755

fabioA

Hello,

Since the theme enfold was supported I've created a website with WPML creating 3 more languages. As soon as I put online the website the backend got incredibly slow, like 30 sec to open a web to modify the content...what should i do?

thanks,

Fabio

January 28, 2014 at 10:44 am #328870

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello Fabio,

Agree with you, 30 secs loading way is just too long.

# Could you check the following points for us?

1) Is the Frontend also slow?

2) What WPML plugin versions are you currently using?

3) What is your current PHP memory limit? 64 MB minimum is required.

4) http://wpml.org/faq/why-string-translation-appears-to-slow-down-sites/
Are perhaps options "Track where string appear on the site" + "Auto register strings for translation" active?

5) http://wpml.org/faq/how-to-optimize-mysql-queries/ > heading "Auto ID Adjust"
Is option "Adjust IDs for multilingual functionality" active?

6) Check for hidden PHP errors with http://wpml.org/documentation/support/debugging-wpml/

7) Bit more complex.. please try this...
> get extension "Firebug" for Firefox - if don't have it yet
> open your website in FireFox
> open Firebug with the "Bug" button in the top right corner of the browser window
> go on tabs "Net" and then a little below to "All"
...ok, then...
> press F5 to refresh

In the lists of results below...
- are there any links in red, with "Status 404 not found" or "500 Internal server error" ?
- any files/links which take extraordinarily long to load?

Thanks a lot!

January 29, 2014 at 8:19 am #329448

fabioA

Hello Andreas,

thank you for your detailed answer. here below you'll find my answers:
1) bit slow yes (like 2-3 sec opening the home using firebug detection
2) latest version...updated (with wordpress 3.8.1)
3) php memory limit 192mb (very high)
4) both options inactive
5) there are no really php errors and using firebug i've detected some plugins making the backoffice slower...but also if I tried to deactivate them the backoffice is still slow...

what should I now check?
fabio

January 29, 2014 at 12:32 pm #329709

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello Fabio,

Thanks a lot for the feedback!
I think with these steps you have done all you could from your end.
We have to examine this now really from our end deeper.

# Would you mind providing us with credentials for your website and we have a closer look at the settings? For this purpose you should see a protected webform all they way down here in this thread. (it asks first for "Backup + Legal disclaimer")
Thanks in advance!

February 14, 2014 at 4:01 pm #340117

fabioA

Hello,

I'm very sorry for my delay but we just moved the website to another server. The situation didn't changed and the backend seems still slow...

I sent you all the access you need

I would really appreciate if may check why the backend is so slow 😉

thank you in advance,

Fabio

February 14, 2014 at 7:41 pm #340339

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello Fabio,

No problem - time worked actually for your advantage..

We released a new set of WPML plugins + very important bug fixes in the last 48 hours.
To make updating easier for you I took the freedom to install our "Installer" plugin for you.

# Could you update your WPML plugins* and let me know if this improves the speed for you?

Thanks!

--
* best after a database backup (with phpMyAdmin -> Export or so)

February 20, 2014 at 4:20 pm #344409

fabioA

Hello,

I've just uploaded the plugin but the backend is still really slow.
I think also that the frontend is quite slow?

anything else I should do for getting faster?

thanks,
Fabio

February 21, 2014 at 8:54 am #344772

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello Fabio,

Checked your WPML plugins - currently you are still using version 3.0.2-a
Not a bad version but it doesn't contain our very latest performance improvements.

I really recommend to replace your current WPML plugins with the ones from our 3.1.4 beta package.
You can get it from your WPML account. Go to Downloads, scroll to the bottom and you will see the beta package. Right now, it's 3.1.4-b4

This ZIP includes several ZIP files of the individual WPML components. First, unzip it locally, get the parts that you need and upload them.

The safest way to update the plugins is to:
1. Deactivate (don't worry, your content doesn't change)
2. Delete the folders with the older versions
3. Upload the new versions
4. Activate

Please let us know if this version improves the speed - if not I'd like to involve a developer to have a look at your site.
Thanks a lot!

March 1, 2014 at 2:47 pm #349981

fabioA

Hello,

I just found out that the problem is related to the use of another plugin with wpml. WordPress SEO plugin...as soon as I disabled on or the other the website speed up...

March 3, 2014 at 11:28 am #350653

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello Fabio,

Glad to hear that you were able to pinpoint the cause of the speed problem.
Not use "WordPress SEO" is not really an option for you I guess.

# In seconds - how much is the speed difference? (~about)

March 7, 2014 at 2:52 pm #354477

fabioA

speed difference is a lot in the backoffice...from 2 sec to open a page without the plugin activate to more than 10 seconds! I've deactivated the plugin i won't use it anymore...thanks