Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 3 voices.

Last updated by Mihai 6 years, 10 months ago.

Assigned support staff: Mihai.

Author Posts
March 8, 2013 at 9:02 pm #110229

Oleksandr

When WPML was enabled, the website became dramatically slow, the pages are loading now for 50-60 seconds. Before enabling WPML it was very quick as 1-2 seconds for loading.

We have tried all the recommendations from the website and we use only the last updates for all plugins and WP.
I do not have images at website or anything that takes so long time to load the pages.

my domain is hidden link

March 9, 2013 at 4:52 am #110235

Harshad

Dear Oleksandr,

Do you have WPML String translation plugin installed?

March 9, 2013 at 1:38 pm #110250

Oleksandr

Yes, it is installed.

March 9, 2013 at 2:24 pm #110251

Harshad

Dear Oleksandr,

Here are a few things you can try:
http://wpml.org/2012/01/can-your-site-run-faster/

March 9, 2013 at 7:44 pm #110272

Oleksandr

I have tried everything from here and nothing helped.

March 10, 2013 at 8:00 am #110307

Harshad

Dear Oleksandr,

This FAQ entry might be relevant for you:
http://wpml.org/faq/why-string-translation-appears-to-slow-down-sites/

You should also enable a plugin called 'Debug Queries' and show us the DB queries that his site is generating, with and without WPML's String Translation.
http://wordpress.org/extend/plugins/debug-queries/

March 12, 2013 at 9:45 pm #111089

Oleksandr

We sent debug queries with and without WPML to your e-mail (subject: debug queries). I am looking forward to your help.

March 13, 2013 at 8:03 am #111153

Harshad

Dear Oleksandr,

Thanks I got your email, I have forwarded the logs to our Development team for analysis.

I am assigning this ticket to our main developer Mihai.

Please standby for further updates.

March 13, 2013 at 8:35 pm #111408

Mihai

Hi Oleksandr,

Are you sure you have disabled 'track where strings appear on the site' ? (according to http://wpml.org/faq/why-string-translation-appears-to-slow-down-sites/)

It doesn't look like from your queries list.

March 13, 2013 at 11:59 pm #111442

Oleksandr

Dear Mihai,

I did it many times but the settings are returning. I mean that I saved settings (disabled 'track where strings appear on the site') but 'a tick' in a box is returning.

(I saved and it worked approximately for 10 seconds and when I refresh a page it returned to the previous settings.)

Thank you for helping me to solve this issue.

March 14, 2013 at 1:07 am #111446

Oleksandr

Dear Mihai

Please ignore previous message. I disabled it but still the debug query shows that website has 620 queries. Can you give your e-mail please I will send you debug queries list?

April 22, 2013 at 10:05 am #121480

Mihai

Sorry for the delay on this Oleksandr. You can email me at mihai@wpml.org of you're still having this issue.

April 23, 2013 at 12:29 pm #121904

Mihai

I got your email, thank you.
Can you confirm what WPML version are you using now (including the addons) ?

Also - from your email I see that the "Total query time: 0.80739s for 384 queries."
0.80 seconds is a reasonable time and only some of the queries are being made by WPML.

Were you able to break down the difference of performance between using and not using WPML?

The topic ‘[Closed] website is dramatically slow due to WPML’ is closed to new replies.