This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Bobby 3 months, 1 week ago.

Assigned support staff: Bobby.

Author Posts
July 11, 2019 at 8:05 pm #4193025

hesselK-2

if i go to hidden link it is not doing sowmthing when i click to /nl/ /de/ /en/

it is redirect me to .com/

also i want the following:

when people go to hidden link they will be always redirect to /nl/ or /de/ or /en/
so i dont want any custemer on /

Now the dutch is showing on .com/ but i also want this to go to .com/nl/ because my dutch website is redirected to .com/nl/

July 11, 2019 at 8:09 pm #4193031

hesselK-2

[removed for security ]

This is the bizzy month for us so i woud be happy if sombody can look at this

What is want:

the website hidden link will always redirect my dutch clients to hidden link my english to /en/ and german to /de/

July 11, 2019 at 8:10 pm #4193033

hesselK-2

i mean https:// not http://

July 11, 2019 at 8:39 pm #4193061

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

thank you for the access details ([please keep in mind that this is a public forum])

the reason you are not able to view the secondary language is because at the moment there are no translations , if you go ahead and translate your home page you should be able to access them

additionally if you wish your users to see hidden link instead of hidden link for the Netherlands translation you have to go to WPML->languages-> enable "Bestandsmap gebruiken voor standaard taal"

let me know your results please

July 11, 2019 at 8:57 pm #4193081

hesselK-2

thanks great worked, also how do i use this :

Advanced Translation Editor
or how do i buy it ?

July 11, 2019 at 9:04 pm #4193127

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Glad to hear that !

here is our official documentation on WPML Advanced Translation Editor

https://wpml.org/documentation/translating-your-contents/advanced-translation-editor/

you get a free quota of 2000 words and you can buy more if needed

-> https://wpml.org/2018/12/machine-translation-quotas-for-wpmls-advanced-translation-editor/

to activate you go to WPML->Settings->Select advanced translation editor and it should be activated (you will receive an email afterwards)

let me know your results

July 12, 2019 at 7:05 am #4195699

hesselK-2

thanks Bobby,

only 2 problems :

1. i cant find the advanced translater in my menu and i dont see a link to order the pro pack can you help me with tath?

2. also when i go to my homepage like .com/ the page is blank if i go to .com/nl/ or .com/en/ it works how can i redirect .com/ to nl or en based on langause ?

July 12, 2019 at 5:25 pm #4200679

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

1. If i go to WPML->Settings i can see that Advanced Translation Editor is activated (ATE)
to buy more words you can click on "advanced editor settings" link takes you to hidden link then click on "buy words"

https://wpml.org/documentation/translating-your-contents/advanced-translation-editor/automatic-translation-pricing/

you can go to Pages->Edit any translation and it will be accessed with ATE

2. your URL structure now contains /nl/ for your default language therefore .com/ by itself is not a valid url , since browser language redirection is enabled the user will be redirected to either /nl/ or /en/ automatically depending on their browser's language.

i have test this and it works for me as expected , everytime i try to visit .com/ i am redirected to /en/

July 12, 2019 at 7:24 pm #4201383

hesselK-2

oke this problems are solved , i am more loving the program every day!
last question i have now translated automaticly all post and pages only with the blogs i got a big internal linking now i use the option "translate linktarget" in settings it saying 50.000 now the problem is it never gets to 50K because then it stuck can i do this in a cron?

July 12, 2019 at 7:27 pm #4201387

hesselK-2

also the media tublies so featert image is now showing on any page.

July 12, 2019 at 10:54 pm #4201767

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

glad to hear the issue is resolved , if possible please open a new thread in our support forum regarding the link target translation as it might need some further looking into and we try to keep each ticket to 1 issue per open thread

Kind Regards,
Bobby

The topic ‘[Closed] website is not showing /en/ /de/’ is closed to new replies.