This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 13 replies, has 3 voices.

Last updated by fidanD 4 months, 3 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
April 16, 2019 at 2:53 pm #3623247

fidanD

Tell us what you are trying to do?
I just installed the plugins and I'm using the subdomain option. Ever since installing and inserting the language switcher the website is terribly slow. I kept on reading the forum, but nothing is helping. PHP is 7.1.27, WP is 5.1.1. Memory Limit is 1024M

What is the link to your site?
hidden link

April 16, 2019 at 11:07 pm #3625917

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

please review the following documentation and let me know your results

=> https://wpml.org/faq/prevent-performance-issues-with-wpml/

additionally which plugin or method are you currently using to compare the performance of the site with and without the WPML plugins ?

April 17, 2019 at 7:30 am #3627743

fidanD

To be honest, I've written almost everything you have written about it and nothing helps. The ID stuff, the string stuff, it makes no difference.
And I know for 99% sure it's your plugin, since the website was fine before implementing it. I had never noticed any delay before and now you can't ignore it. I don't understand why... 🙁

April 17, 2019 at 8:21 am #3628443

fidanD

Of course I meant, I wrote almost everything you have written....

April 17, 2019 at 8:42 am #3628639

fidanD

I read almost everything...

April 17, 2019 at 10:11 pm #3634853

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

You are using the String Translation which can be a more intensive plugin due to the scanning of the strings, that is why i wanted to verify that you followed the instructions as they will help to reduce the impact

I understand you can see the load time , but it is important to use a plugin to measure the queries and load time with WPML and without WPML , also what are your results when WPML String Translation is deactivated

as that will help us to try and understand what might be causing the issue as performance issues can be quite complex.

This is a more detailed guide
=> https://wpml.org/faq/how-to-debug-performance-problems/

As of right now i have run the pageSpeed insights by Google if possible please deactivate WPML and share with me a screenshot of your results additionally let me know the results of the following plugin as well

-=> https://wordpress.org/plugins/query-monitor/

April 18, 2019 at 2:52 pm #3640127

fidanD

Allright, so I have deactivated and my score has not improved. It showed 15 before and after, which still is strange.
Im not sure how to get report, So Ive added another screenshot. If you want, I can make an account for you?

April 18, 2019 at 8:19 pm #3641787

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

yes if possible i would like to take a closer look at your backend

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

April 24, 2019 at 6:18 pm #3675827

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
My name is Carlos and I will be taking this ticket from now because my colleague Bobby is off today.

Thank you very much for providing the credentials. I visited the site and I can see that the WPML plugins aren't updated. The latest version of WPML plugins includes several fixes for performance issues.

I kindly ask you to update all outdated plugins, specially WPML plugins, to their latest version and check if the issue persists.

Looking forward to your message.
Best regards,
Carlos

April 26, 2019 at 8:33 am #3688859

fidanD

Hi Carlos,

Thanks for the message. I have just updated them.
Please let me know what to do.

April 26, 2019 at 2:05 pm #3691339

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your feedback.

I have applied several troubleshooting steps in the site and increased the memory limit and now the site seems to be loading correctly. Could you confirm that the issue is solved?

Regards,
Carlos

April 29, 2019 at 12:27 pm #3703131

fidanD

Hi Carlos,

It doesn't seem to be fixed: hidden link

I also notice it while loading the website by myself. It might have something to do with something else. It just wasnt a problem before WPML.

April 29, 2019 at 8:38 pm #3706573

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you for your feedback.

Yes, I was able to see the issue this time, which seems strange since after I applied the troubleshooting steps the site seemed to be loading fine.

In this scenario I kindly ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Update all outdated plugins and themes.
- Flush all cache memory.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

Regards,
Carlos

May 29, 2019 at 9:20 am #3913865

fidanD

Hi Carlos,

Sorry for not replying sooner, but the issue still exists. And really, if I deactivate all plugins the website is really fast. At the moment I start WPML, the website is instantly slow. I just don't understand why it's so hard to help me with this?