This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by ullaJ 1 year ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
September 27, 2018 at 1:38 pm

ullaJ

Hi, My website is redirecting to english version eventhough i set default language as danish, However when i open landing page it shows in danish language but when i click on any product it redirect to english version of product.

Furthermore even if i choose danish language in product page it again redirect to english version.

September 28, 2018 at 7:41 am #2772763

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

Have you set any redirections on your site? or any plugins that are creating redirections?

The issue seems like a theme/plugin conflict or a PHP error that is blocking some functionalities and creating such issues, so could you please perform the below steps and let me know if that helps?

Minimal Setup
If you disable all non-related WPML plugins, switch to one of default themes, the problem persists or not?
NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

Debugging
1. Please follow the debugging information provided here: http://wpml.org/documentation/support/debugging-wpml/ .
2. Repeat the action of creating the problem.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see.

Look forward to your reply.

Thanks

September 28, 2018 at 9:40 am #2773152

ullaJ

Hi Shekhar,

I disabled all the plugin and tested my site and still facing the same issue. I even followed your guide but still same issue. so can you please login to admin/cpanel and check it by yourself.

September 28, 2018 at 12:22 pm #2773750

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

This seems unusual, I checked your htaccess and I couldn't find any problem there too, to further debug this issue I would need to replicate your site on my localhost and perform further debugging, so, could you please provide me a backup of your wp-content (without uploads) as well as database backup so I can replicate your site on my localhost and perform further debugging.

You can zip these files and upload to google drive later to share it with me.

Enabled the private reply for you.

Thanks

October 11, 2018 at 7:50 pm