This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 4.19 hours from now. Thank you for your understanding.

This topic contains 36 replies, has 2 voices.

Last updated by Itamar 3 months, 1 week ago.

Assigned support staff: Itamar.

Author Posts
April 6, 2019 at 4:51 pm #3549677

mohamedalkamelM-2

I am trying to: website is too slow

Link to a page where the issue can be seen:

I expected to see:

Instead, I got:

April 6, 2019 at 5:24 pm #3549719

mohamedalkamelM-2

after installing wpml my website is too slow

April 7, 2019 at 5:22 pm #3552689

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I'll help you with the performance issue that you have on your site.

Is your server meeting WPML's minimum requirements?
Our recommendations are to have the following as minimal requirements:
- PHP 5.3 and above with a WP Memory Limit of at least 128MB and more if possible.
- MySQL 5.6 and above.
Please follow this link for a detailed documentation:
https://wpml.org/home/minimum-requirements/
Please check that and correct if needed and then check if the performance issue persists.

Could you please share your Debug information with me?
You can read the detailed explanation about it here.
http://wpml.org/faq/provide-debug-information-faster-support
The debug info will give me a lot of information about how your site is configured and will help me understand the source of the problem.

Thanks,
Itamar.

April 7, 2019 at 10:19 pm #3553089

mohamedalkamelM-2

i have php 7.1 and memory limit is 256 everything is fine and ok but still its not just slow but absolutely slow, wasted my two days the work that i do in two hours , i am really disappointed with this plugin.

April 8, 2019 at 12:39 pm #3557675

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I'll do my best to help you solve this performance issue.

Please go over our documentation at the following link. There you would find suggestions to improve the performance of the site.
https://wpml.org/faq/prevent-performance-issues-with-wpml/
If all the suggestions are implemented on your site and the performance issue persists, then please try the following procedure.

I suspect that there is a collision with the theme or another plugin that might cause this performance problem. If possible get your site into a minimum environment. Minimum environment means switching to a default WordPress theme like Twentyseventeen and no plugins activated except WPML.
Is it possible for you to try it?
You will need first to check if the problem persists when just the theme is switched to Twentyseventeen (for example). If it persists then deactivate all plugins except the WPML and its add-ons and WooCommerce itself. Then please check if the problem persists. If it does not persist so start by activating the plugins one by one and check when the problem comes back, then report to me which was the culprit plugin.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****


*** If your site is a live site you might want first to try those procedures in a staging environment or a snapshot of your site on your local server or another server. ***

Thanks,
Itamar.

April 8, 2019 at 8:41 pm #3561213

mohamedalkamelM-2

Everything mentioned in this article https://wpml.org/faq/prevent-performance-issues-with-wpml/ is there and have already done. NO success , And i can't deactivate all the plugins and theme , this is not a solution and an easy task to deactivate one by one and then again activate it and so on , I am pretty sure the problem is in your wpml plugin and every one is complaining about the speed. If you can't help me please let me know . Thanks

April 8, 2019 at 10:08 pm #3561515

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Please let me have access to your site and explain to me where I can see the slow performance on your site.
Is it happening on certain pages?
Is it happening on the front-end or the backend?
Then I would like to test what is the loading time difference when WPML is active and when it is not active.

Thanks,
Itamar.

April 16, 2019 at 10:54 am #3621149

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for the access details.

I've checked all the settings on your site according to this documentation.
https://wpml.org/faq/prevent-performance-issues-with-wpml/
Indeed everything is set correctly. You gave me access with a user which is not an admin user, and I cannot continue to check thing like that. Furthermore, you have mentioned that you do not want to deactivate the theme and third-party plugins. But to debug the performance issue, I'll need to do that. Currently, I can see that it takes around 13 seconds for the homepage of your site to load. I'll need to check the time that it takes it to load when WPML is not active. Due to all this, I think that it would be better if we will continue to debug this performance issue on our test server. In the next private message that I'll add in a few minutes, I'll share with you all the details of how you can clone your site to our test server. The process is easy. On our test server, I'll have full access to your site including access to all the site's folders and files, and this would enable me to debug the issue properly. It is also important for me to mention that the performance of your site might also be affected by the server that it is hosted on. Sometimes shared hosting plans tend to be less optimal performance wise.

Thanks,
Itamar.

April 21, 2019 at 2:07 am #3651093

mohamedalkamelM-2

No need to shift there , we have this site on test server also and from different hosting server (godaddy) but still the same problem with speed,

also tested with hidden link the load time is 20 with wpml
after deactivation load time is 3.6 now you can imagine how much the difference it is .

You should be assure that the problem is with your plugin .

here you can do whatever you want with site

hidden link

--removed by supporter--

And let me know when you resolved the issues so that i could do with the live site.

wasted too much time and its my biggest mistake in my life to use this plugin.

Thanks

April 22, 2019 at 8:46 am #3654623

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I cannot see such a big loading time difference as you describe when WPML is active and when it is not. You told me that when WPML is active, the site is loading in 20 seconds, but I get different results. I get around 5 seconds load when WPML is active and around 3.5 seconds load when WPML is not active. Please see the video that I've recorded hidden link. Having this 1.5 seconds of overloading time with WPMl and so many plugins on one site is not such a bad result. In any case, I'm still continuing to check if this can be improved. I'll get back to you here when I have more information.

P.S. For your site's safety I've removed your site's credentials from this thread. This is a public forum so please refrain from posting sensitive to the public replies. If need we will enable private reply.

Thank you for your patience.
Itamar.

April 22, 2019 at 9:13 am #3654763

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I've continued to debug the performance issue on your site. First I've updated all the plugins. Especially it was important to update WooCommerce and WooCommerce Multilingual. The performance issue continued as it was before with around a 1.5 seconds difference when WPML is active or not active. Then I wanted to continue debugging the issue, so I tried to deactivate the theme and activate the default WordPress theme 2019. Just after that, I did that I've received a 500 error for your site and I can't continue to work on it. Please see the attached screenshot.

Could you please check this problem and correct it and tell me when your site is working again?

Thanks,
Itamar.

April 22, 2019 at 12:22 pm #3655667

mohamedalkamelM-2

As i told u i have already checked these things no need to spend time on those plugins and theme activation and deactivation i have done these all already so for me it's pretty clear that wpml is reason/cause of slow speed .

Give me a solution now , nothing more than that.

Now as you know we have spent too much time to Translate the entire website , now it's due to compulsion we will use it in future for this site .

April 22, 2019 at 6:32 pm #3657865

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I understand that you have already found out that if you deactivate WPML the site is running better. The purpose of deactivating the theme and the plugins is to find if any of them conflicts with WPML. And this is what I need to do. Please understand that we have debugging procedures to follow. Those are procedures that we have developed based on our experience with issues like that. Of course, if I've had a quick solution for I would have given it to you immediately. Now I need to continue and debug the issue on your site. For this, I'm also following the instructions here.
https://wpml.org/faq/how-to-debug-performance-problems/
I've already installed the Debug Objects plugin (https://wordpress.org/plugins/debug-objects/). But now I also need FTP access to your site which you have not shared with me until today.
Could you please share with me the FTP credentials to your site?
For this, I'm enabling a private message for the next reply.

Thanks,
Itamar.

April 23, 2019 at 5:55 pm #3666681

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hello and thanks for the FTP details.

I've checked things on your site according to instructions that we have on this page.
https://wpml.org/faq/how-to-debug-performance-problems/
When I tried to use the Debug Query plugin on your site I've received a fatal error which didn't enable me to continue the chacked when everything is activated. So I needed to move into a minimal environment. Deactivating the theme on your site also caused a fatal error. So I needed to use some FTP manipulation to be able to access the site again. Currently, the site in on minimal environment when only WPML and its add-ons and WooCommerce are active and the default WordPress theme 2019. Still, I can see a slow loading time on the translated homepage here. hidden link. It is loading in around 8 seconds. Using the Debug Query plugin, I can see a lot of queries, and I think that the issue is related to cache. I say it because the queries say:

Function: WPML_Element_Translation->maybe_populate_cache()

I can also see by looking at your server information that OpCache is not enabled on the server (and maybe also the Objectcache https://codex.wordpress.org/Class_Reference/WP_Object_Cache). Here you can find more information about the PHP Opcache and WP_Object_cahce.
hidden link
https://codex.wordpress.org/Class_Reference/WP_Object_Cache
In our documentation here we are mentioning that it is recommended to have it enabled on the server.
https://wpml.org/2012/01/can-your-site-run-faster/
I could check your server information here.
hidden link

I'm currently consulting our second tier supporters about all of the findings from your site. When I have an answer from them I'll get back to you here.

Thank you for your patience.
Itamar.

April 25, 2019 at 11:30 pm #3686337

mohamedalkamelM-2

Are you there? How many days it may take more?