This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 1 reply, has 2 voices.

Last updated by Bruno Kos 5 months, 2 weeks ago.

Assigned support staff: Bruno Kos.

Author Posts
May 2, 2019 at 8:24 am #3722667

kevinB-5

We've been using WPML on hidden link for a while now. Performance wise it's not very good. We have multiple websites with the same configuration, but without WPML. They are significantly faster.

I've also tried to optimize WPML, but I didn't see any real result.

I do see a difference when I de-install String Translation. A big load disappears, coming from the home_url action, when we de-install the String Translation plugin. But at the moment we need this plugin for several translations.

Link to a page where the issue can be seen:

hidden link

--

Is there anything you can do to speed things up?

May 2, 2019 at 11:38 am #3724167

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

String Translation can cause slowness on some hosts, especially if String Translation has tens of thousands of strings coming from various plugins that are mostly not used or need no translation. If none of these suggestions work:
https://wpml.org/2012/01/can-your-site-run-faster/
https://wpml.org/forums/topic/how-to-optimize-wpml-performance/

See this - this is what one of our clients did and based on their benchmarks, the site was very fast after this - they even did some direct changes on databases, loaded some strings from mo files instead of database, etc.
https://wpml.org/forums/topic/slow-wpml-performance/#post-3229765

If none of above help, please see this:
https://wpml.org/forums/topic/wpml-drastically-slow-down-my-site-2/page/2/#post-3541827
https://wpml.org/forums/topic/extra-slow-site-after-installing-wpml/

Basically, what I suggested those clients (and it helped) is that they clear database from unused strings and then disable the setting which auto registers strings from new domains. This will however require a certain amount of work.

Please make a full backup of your site before trying any of this or make these changes on a staging/development site!

Regards,
Bruno Kos