Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 2 replies, has 2 voices.

Last updated by Alejandro 1 year, 5 months ago.

Assigned support staff: Alejandro.

Author Posts
April 1, 2019 at 11:26 am #3507201

Apulia Vending s.r.l.

Dear support,
as I enable the WPML main plugin the website's page are not loaded correctly.

I already increased the memory limit but it looks like it is not detected.

Hope you can help

Thanks in advance.

April 1, 2019 at 12:12 pm #3507681

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao!
Benvenuto al supporto cliente WPML.
Farò del mio meglio per aiutarti a risolvere questo problema.

Vedo che ancora hai il valore che viene per default nel sistema (mi compare 40M sulle informazioni di debug che mi hai inviato), quindi forse c'è stato qualcosa che non è stato fatto bene.

Vai sul file wp-config.php e controlla che un codice simile a questo sia stato inserito prima del commento "That's it, stop editing. Start Blogging"

define('WP_MEMORY_LIMIT','128M');

una volta che avrai fatto questo e per controllare che questa volta sia tutto apposto vai su WPML > Assistenza e poi controlla verso la fine della pagina dove compaiano le informazioni di memoria, che una dica "128M" (WP Memory, quella che ci interessa), l'altra invece (Max Memory Limit) Dovrebbe dire "256"

vedi se questo risolve il problema e se non è così, potresti per favore descrivermi con dettagli questo problema?

Fammi sapere.

April 2, 2019 at 1:23 pm #3517603

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Allora, vedo che appena attivo il registro di debug vedo questo errore costantemente:

[02-Apr-2019 12:37:19 UTC] PHP Notice: Il metodo di costruzione richiamato per WP_Widget è deprecato dalla versione 4.3.0! Utilizzare invece <pre>__construct()</pre>. in /home/web/webserver/pugliavventura/public_html/wp-includes/functions.php on line 3568

questo compare quando WPML è disattivato ed è molto probabile che succeda perché il codice del tema (che immagino sia quello che gestisce i widget) non sia stato aggiornato.

Se invece l'attivo (WPML), la pagina rimane bianca, e il problema qui sembra è di nuovo il tema. Ha un problema con il plugin "tgm plugin activation" (immagino si tratti dell'attivazione del tema) e anche diversi errori nel header, che poi alla volta fanno crashare WPML.

Ti consiglio di aggiornare il tema all'ultima versione o di parlare con l'autore del tema perché lo renda compatibile e aggiornato con WordPress e WPML.

Puoi dirgli di scriverci tramite questo form e noi l'aiuteremo gratuitamente, se riscontra qualche difficoltà: https://wpml.org/documentation/theme-compatibility/go-global-program/

Saluti.