This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 10 replies, has 2 voices.

Last updated by Bigul 4 months, 1 week ago.

Assigned support staff: Bigul.

Author Posts
May 24, 2019 at 6:02 pm #3886929

ruslanP

I found out WMPL CMS is slowing my website! I read some topics, but it seems the problem is "active"

Please any help!

I can't provide debug info because I deactivate the plugin.

May 25, 2019 at 3:04 pm #3889631

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Which type of hosting service you are using, shared or VPS or Dedicated?

Is it possible for you to consider a staging site(clone copy of live site) on the same server? So we can debug the issue further without affecting your live site.

Please let me know your feedback.

--
Thanks!

Bigul

May 28, 2019 at 12:21 pm #3906809

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the staging site details. But for the performance debugging we need the actual theme and plugins. So can you please make a copy of your live site. You can use the Duplicator plugin for this purpose. Please check the following links for more details.

https://wordpress.org/plugins/duplicator/

hidden link

--
Thanks!

Bigul

May 28, 2019 at 5:30 pm #3909091

ruslanP

Unfortunately my WP site is too big for the free version, but the PRO one is 60$. How about if I make backup of the website so you can configure without any hesitation the current one. If something goes wrong we will just restore it.

Best regards,
Ruslan

May 29, 2019 at 7:53 am #3912687

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Ruslan,

Thank you for the updates. Which hosting service you are using now? Maybe it will be easy to make a copy of the live site from your hosting control panel. Please check it and let me know your feedback.

Also please try you can make a Duplicator package without *Media files* and *wp-content/uploads* folder(with free version). Please check the attached image for more details.

--
Thanks!

Bigul

May 29, 2019 at 9:33 pm #3918727

ruslanP

Okay you are ready. Same credentials.

May 30, 2019 at 5:20 pm #3925319

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Ruslan,

Thank you for the updates. I went through few of the backend and frontend pages after the following steps. All of the pages are loading in around 5 seconds for me. Please check the attached images.

1) Upgrade the theme to the latest version
2) Upgrade the plugins to latest version including WooCoomerce & WooCommerce Multilingual
3) Include all string domain for auto-registering

Therefore I would like to know the following to track the issue.

a) Which type of hosting service you are using, shared or VPS or Dedicated?

b) In which page or section you are facing the least performance

--
Thanks!

Bigul

June 1, 2019 at 5:31 pm #3935735

ruslanP

Hello again,

this is too much time for loading website without media and the other stuff. Please check it again and set the things correctly.

Also I would like to request an answer regarding this thread which isn't solved:

https://wpml.org/forums/topic/custom-field-is-not-synched-copied-to-translation-2/

Best regards,
Ruslan

June 3, 2019 at 2:29 pm #3943449

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Ruslan,

Thank you for the updates. I made a change in the settings, now String Translation is disabled for Themes & Plugin translation. So please check is there any improvements in the Site performance.

Please let me know the following details for a better understanding of the issue.

a) Which type of hosting service you are using, shared or VPS or Dedicated? Because I got Web server error a few times.

b) In which page or section you are facing the least performance. In my tests site is loading in 3-6 seconds most of the time.

Please check the attached images.

About the other thread, I have requested Marcos to check it. Please wait.

--
Thanks!

Bigul

June 6, 2019 at 4:08 am #3965805

ruslanP

Hello again,

Sorry for delay. Shared hosting + CDN. At the moment the website is fast enough I believe. Any updates regarding the Marcos case?

Best regards,
Ruslan

June 6, 2019 at 5:55 pm #3971371

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Ruslan,

Thank you for the feedback. Happy you to know you are getting better results now.

Please note, Marcos is currently working on the issue and get back to you soon. Please wait.

--
Thanks!

Bigul

The topic ‘[Closed] Website performance is slow with WPML’ is closed to new replies.