Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.


This topic contains 3 replies, has 2 voices.

Last updated by Dražen Duvnjak 1 month, 3 weeks ago.

Assigned support staff: Dražen Duvnjak.

Author Posts
February 24, 2021 at 2:50 pm #8164553


We tried the suggestions on the forum like disabling tracking ID's, Automated String translations, but to no luck.

Load time go up to 20 seconds or higher. Disabling the WPML Multilingual CMS increases the performance significantly.

We use:
- Woocommerce
- Elementor
- Ocean WP
- Lightspeed caching

February 26, 2021 at 9:40 am #8179457

Dražen Duvnjak

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)


Welcome to WPML Support.

I'll do my best to help you solve this issue.

- Please make a backup before proceeding.

1) Please update all WPML plugins to the latest version by going to the Plugins → Add New page, click the Commercial tab, and then click Check for updates.


2) Does the issue happens on default language, translated pages or both?

3) Can you please check if the issue happens when only WPML plugins and WooCommerce activated, all other plugins disabled?

4) Please change your theme to the WP default theme and check if the issue happens.

This will help tell us if the issue happens when a specific plugin/theme is enabled together with WPML.

5) Please go to WPML > Support > Troubleshooting > Clean up and click to run next:

- Clear the cache in WPML
- Remove ghost entries
- Fix element_type collation
- Set language information
- Fix post type assignment

6) Go to WooCommerce > WooCommerce Multilingual > Status > Troubleshooting > Check one option by one and click "Start" to run it.

Please let me know how it goes and don't hesitate to ask if you find any problem along the way or have doubts or questions about the steps mentioned above, I'll do my best to help you in the best way possible.


March 1, 2021 at 9:51 am #8195223


Hi Drazen,

Thank you for your reply. We working on setting up a staging environment, so we can reproduce the problem. As soon as we have that working, we can provide you with the answers to your questions.


March 1, 2021 at 12:02 pm #8196821

Dražen Duvnjak

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello Paul,

thanks for getting back.

Sure, sound great.

Let me know how it goes.

Kind regards,

The topic ‘[Closed] Website product pages are incredibly slow when WPML Multilingual CMS is actived’ is closed to new replies.