This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by sarahD-11 1 month ago.

Assigned support staff: Yvette.

Author Posts
September 6, 2019 at 8:38 pm #4527343

sarahD-11

I am trying to:
open all my english pages from the english menu and elementor preview

Link to a page where the issue can be seen:
hidden link

I expected to see:

Instead, I got: error 404 or error 500. also i have check with my hosting company and they asedme to contact WPML after a few days that we ty to fix the issue. they say the translation is not well configured with WPML...i can see a lot of lines on the side of my pages( please see print screen)

September 9, 2019 at 10:10 am #4535859

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

I´ll be helping you with this.

Temporary Access to your system
Please provide access to your system (wp-admin and ftp) so that I can further investigate this particular problem. The fields to provide this data are included in a private section that I will open for your next response. You can find it above the comments area. The information in this private section is only visible between WPML Support and you.

September 13, 2019 at 9:27 am #4566979

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

I see that this "menu" is actually an elementor "modal popup" and not a WordPress menu.

I took a look at you site and noticed that you had not translated the modal popup.

- So, I translated this modal popup to EN: Menu-keylime-EN-aout-2019
- I set this to be visible across entire site.

- I then updated the EN version of the header template to point to this modal popup (see image).

Once these steps were done, I was then able to see the translated modal pop-up and select the items.

I think this now resolves your issue.

September 13, 2019 at 10:23 am #4567435

sarahD-11

Thank you! no more error 404! you are great! thank you for your help!
May I ask which image are you talking about??
I don t see any errors anymore !
I didn t know i had to translate menu templates and not only wordpress menus