This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Raja Mohammed 5 months, 3 weeks ago.

Assigned support staff: Raja Mohammed.

Author Posts
April 15, 2019 at 5:35 pm #3615363

Vassilis

I have been struggling with the following for numerous hours.

Seems like there is a bug on the Cookie for Ajax filtering.

Problems arise when the user is not logged in, when logged in, all is working like a charm.

With the cookie for ajax enabled, the Google map that fills after Ajax call, when visiting the English property page for the first time (probably the cookie is not already set?), map does not fill with any content, and only after a refresh/reload displays content.

Moreover, map is showing content in the previous language, after a language switch. It is only after a refresh, that loads content in a correct language.

I have a staging version of the website:
IP: 172.104.247.198
Everything is up to date. Debug info submited are from the staging website.

Test URL EN: hidden link

Test URL EL: hidden link

April 16, 2019 at 7:14 am #3618755

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Welcome to our forum,

I' am unable to check the issue as the URL you have posted is returning a 404 error. Kindly fix the 404 issues.

Please share temporary access to the staging site. I have enabled private reply for you to securely share the details. This will be helpful to check the issue and provide a faster solution.

Kind regards
Raja

April 16, 2019 at 2:59 pm #3623261

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Thanks, I can access the site and I'm able to reproduce the issue. This is quite weird, I might need to check this with our experts for more information. I will get back to you with the updates.

Please note I have temporarily changed the WP backend to English while I debug the issue.

Regards
Raja

April 17, 2019 at 8:17 am #3628431

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Thanks for your patience, This seems like a compatibility issue. Please install the theme to the sandbox and try to reproduce the issue => hidden link

You will have access to a clean WordPress installation, WPML is already installed. please activate and complete the setup. Add a test property and check whether the issue can be reproduced. This is an effective way to isolate the issue and escalate if there is any compatibility case.

Let me know once done.

kind regards
Raja

April 20, 2019 at 12:58 pm #3650283

Vassilis

Hello! Could you please escalate the ticket?

I found the problem.

The installation we face the problem is under a folder, on:
hidden link

And there is another install under hidden link

The main problem is that WPML does not set the cookie early enough, and AJAX runs before the cookie has been set.
Moreover, the cookie is not set for the correct path which should be /properties

I checked by setting the cookie early - hardcoded on header.php , and there are no problems whatsoever.

Thanks in advance, waiting forward for your reply

April 22, 2019 at 5:16 am #3653931

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Thanks for the information, I am checking this with the second tier with the information provided. I will update you once I hear from them.

Kind regards
Raja

May 2, 2019 at 4:10 am #3721475

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

HI there,
We are unable to reproduce the issue.
Could you please help us with the theme files. Share a link to the archived theme file.
Maybe it's related to the theme.

It seems you are using a custom theme could you please confirm the same?

Kind regards
Raja

The topic ‘[Closed] Weird behaviour on Ajax frontend translation when logged out’ is closed to new replies.