This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by julieM-11 1 month, 3 weeks ago.

Assigned support staff: Bruno.

Author Posts
July 24, 2019 at 8:17 pm #4277419

julieM-11

I am trying to: use advanced editor

Link to a page where the issue can be seen: settings page

I expected to see:

Instead, I got:

July 24, 2019 at 9:45 pm #4277611

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. This looks like Advanced Translation Editor was unable to register your site and is, therefore, displaying this error message.

I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please, can I install the Duplicator plugin (or All in One Migration) to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

July 29, 2019 at 9:28 pm #4303539

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. In order for me to verify this problem, I need to look in your database. Please, can I install the Adminer plugin so that I can look in your database?

Thank you.

July 29, 2019 at 10:57 pm #4303809

julieM-11

Yes that is fine. I am also trying to figure out how to use the advanced editor and have all my current translations populate in the advanced editor...so if you can help with that too please do...thanks, Julie

July 30, 2019 at 8:33 pm #4310441

julieM-11

Have you made any progress?

July 31, 2019 at 12:30 am #4310813

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Yes. I fixed the problem directly on the database. You can now sync correctly and the error message is no longer displayed.

Please, let me know if I can help with any other questions you may have about it. I'll be happy to help.

Thank you.

July 31, 2019 at 1:46 am #4310889

julieM-11

The Home page opens in the advanced trans editor and all the original spanish translation is there.
The New Classic Page opens in the classic trans editor, even tho I set the settings to advanced trans editor for all content.
The New Classic Page with Advanced Editor does open in advanced trans editor.
The Test Page About Split Peas opens in the classic trans editor.
The Techniques page doesnt open at all in any translation editor, instead when I click the pencil it just changes the entire back end page into spanish.

I WANT THEM ALL TO OPEN IN THE ADVANCED TRANS EDITOR WITH THE ALREADY TRANSLATED SPANISH CONTENT POPULATING THE BOXES and IF THERE IS NEW CONTENT THEN I WOULD TRANSLATE BY PERSON OR BY MACHINE. IS THAT POSSIBLE?

July 31, 2019 at 5:08 pm #4316977

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Pages that you translated before using Advanced Translation Editor should not normally use content already translated. There is a message for this on the WPML configuration page. I will attach a picture for you to see.

For pages that you have already started translating using the Translation Editor but not yet finished - or not even started, but have the translation icon in progress, you will need to send them for translation using WPML Translation Management.

- Click on the WPML > Translation Management
- Select the desired pages
- Scroll down and click on the "Add selected content to translation basket"
- Click on the Translation Basket tab
- Click on the "Send all items for translation"
- Click on the WPML > Translations
- Pages submitted for translation after following these steps should be opened with ATE.

>>> IF THERE IS NEW CONTENT THEN I WOULD TRANSLATE BY PERSON OR BY MACHINE. IS THAT POSSIBLE?

Yes, ATE allows you to do machine translation or manually.

Thank you.

August 2, 2019 at 4:51 pm #4331651

julieM-11

Now I need to get the real site setup and Im getting the same error message. Can you fix it?

August 2, 2019 at 6:11 pm #4332109

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Yes. I will need the credentials and use the Adminer plugin again to be able to edit your database. Your next message will be private.

Thank you.

August 5, 2019 at 8:07 pm #4342979

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. I have fixed your site and now no error message is displayed on the Settings page.

Please, let me know if I can help with any other questions you may have about it. I'll be happy to help.

Thank you.

August 21, 2019 at 6:16 pm #4434535

julieM-11

Bruno, Can you help me again? I tried working with Lauren but it was a dead end.

The numbers in the HTML tables on most pages are not coming into ATE to be translatable. Can you look at all the info I gave Lauren and see if you can help? The last message she gave me did not include a response mechanism.

After that I tried to change the numbers in the string translation window and that worked at first. But then when I go and make any edits to the french in the ATE and resend, the numbers revert back to being incorrect. In french they should look like this...35 000...instead they revert back to 35,000. Use this page as an example: hidden link