This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 6.28 hours from now. Thank you for your understanding.

This topic contains 19 replies, has 6 voices.

Last updated by Jo 3 years, 6 months ago.

Assigned support staff: Thomas.

Author Posts
February 5, 2016 at 10:21 pm #806321

Tushar

I am trying to: Edit Posts

I expected to see: The Post open in Normal Edit Mode

Instead, I got: "#" signs are appended to the URL (www.siteurl.com/wp-admin/edit.php###) and nothing else happens. If I happen to be in a Post I created and click 'Save Draft' then I am taken back to the main Admin Listing page and cannot Edit again.

Steps to duplicate the issue: Must be an editor. As an administrator I was able to Edit all posts with no issues. I also assigned the editor the ability to translate from both languages but this did not seem to resolve it.

This issue has only appeared in the past 2 days after updating WPML to 3.3.6, WPML String Translation to 2.3.6.1 and WPML Translation Management to 2.1.5.

This only appears to be occurring in the second language (Spanish) of the site. The English side appears to be fine.

February 8, 2016 at 9:49 am #806981

Thomas

Hello and thank you for contacting WPML support!

### Increase WP Memory Limit ###

I see your WP Memory Limit is only 40M. Can you please increase it to 128M to avoid any memory issues?

To do so please follow this guide:

http://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

### WPML Cache ###

You may try to reset WPML Cache:

Please go to WPML > Troubleshooting > Support

1. Clear Cache in WPML
2. Clear Ghost entries

IMPORTANT: Please remember to backup your database first before you proceed! You can use a plugin for this if you like (search for WordPress backup plugins), also take a backup your project.

Does this help?

For further information or if you have any questions related to this ticket please do not hesitate to contact us.

February 8, 2016 at 4:24 pm #807482

Tushar

Tried all of the above recommendations to no success. If it helps at all, when I hover over the 'Edit' link the URL I see in the bottom left of Chrome shows me that it's going to be hidden link

February 8, 2016 at 8:44 pm #807658

Tushar

I've narrowed it down in the code to this file in the WPML Translation Management plugin/add-on: plugins/wpml-translation-management/classes/filters/wpmlclass-wpml-tm-translation-status-display.php.

On lines 45-48 there is a filter being run 'wpml_link_to_translation' that accepts 4 parameters/args but only 2 are being passed. If I change the filter's application at these lines to only add 2 args so it becomes

		add_filter( 'wpml_link_to_translation', array(
			$this,
			'filter_status_link',
		), 10, 2 );

Then my problem goes away. So, I suppose it either needs all 4 arguments passed or changed to only accept 2. Since this is a core plugin code change I won't make that as to not screw with updates. Got any ideas for a solution I could throw in our theme?

February 9, 2016 at 7:15 am #807818

Thomas

This looks like a creative solution you found, but I wouldn't recommend it since code customization prevents from future updates.

Can I have a look into your WordPress before forwarding your case to our developers?

### Backup First! ###

WPML recommends a plugin called "Duplicator" (http://wordpress.org/plugins/duplicator/). That will allow you to create a copy of your site and your content.

:: Duplicator instructions
hidden link

Thanks.

February 9, 2016 at 8:32 pm #808659

Tushar

Sorry, we have a lot of sensitive information in this site that we cannot allow anyone outside our organization to have access to. If it helps any further I also see the public function filter_status_link() (in the same document described above) is where the "###" is coming from. Even further this only appears to be happening on 2 post types: the main Posts type and a custom Recipe type that we setup. I tried de-activating all plugins then re-activating to see if it helped but it didn't. There is an if/else if statement in this filter_status_link() function and if I reverse the order of those then the problem is solved as well. There are so many moving parts to that one piece I'm not entirely sure where it may be breaking. I also reviewed all of our settings and the editors having the issues do have access to both languages. Again, the problem only popped up after our most recent upgrade of the plugins to the most current versions.

It looks like the function/filter here: plugins/sitepress-multilingual-cms/inc/url-handling/wpml-url-filters.class.php at line 43 (public function get_edit_post_link) was changed in the update and it's definitely linked to all of what I've described.

February 10, 2016 at 8:48 am #808936

Thomas

I will forward this to our developers.

Thanks for sharing insights and contribution.

February 10, 2016 at 9:39 am #809014

Thomas

One more thing...

You could try to install our Access-Plugin to see if this solves your issue:

https://toolset.com/home/types-access/

WPML’s Translation Management lets you control who translates each piece of content, to what languages. But sometimes, you need to set up something simpler, like allowing a certain user to edit all content in a specific language:

https://wpml.org/2016/01/allow-certain-users-edit-specific-languages/

February 10, 2016 at 4:30 pm #809516

Tushar

Thanks!!

February 11, 2016 at 7:42 am #809957

Thomas

You are welcome. 🙂

February 16, 2016 at 3:09 pm #814327

Tushar

Any update on this? Thanks in advance!

February 17, 2016 at 6:49 am #814892

Thomas

Did you try the access plugin?

It should work as desired.

February 24, 2016 at 10:11 pm #822804

Tushar

Hi, sorry, I did not try the Access plugin, I thought this was being passed on to a developer. My apologies. I did narrow this down specifically to WPML Code. Running a totally clean installation of WordPress with the TwentyFifteen theme and nothing but WPML plugins active I had the same issue. If I turned off the WPML Translation Management plugin the problem went away. I'm sure you can understand why we'd like to get the code fixed instead of just applying another plugin as a sort of 'band-aid' solution.

Thanks!

February 25, 2016 at 8:53 am #823006

Thomas

This issue will be fixed in next release.

Meanwhile:

Install our Access-Plugin (which is free to WPML buyers) to see if this solves your issue:

https://toolset.com/home/types-access/

############

WPML’s Translation Management lets you control who translates each piece of content, to what languages. But sometimes, you need to set up something simpler, like allowing a certain user to edit all content in a specific language:

https://wpml.org/2016/01/allow-certain-users-edit-specific-languages/

February 25, 2016 at 8:53 am #823007

wunderfarm

Any update on this?
2 weeks after the first report there's still no update out. Sorry but with each update WPML becomes more and more unreliable for our small selection of wordpress plugins used on many client sites.