Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Diego Pereira 2 weeks, 5 days ago.

Assigned support staff: Diego Pereira.

Author Posts
November 19, 2019 at 9:00 am

P-Derathe

I am trying to: activate sitepress-multilingual-cms 4.3.4

Link to a page where the issue can be seen: homepage hidden link

I expected to see:

Instead, I got: "Une erreur critique est survenue sur votre site."

The on extension page :
Extension paused
Une erreur de type E_ERROR a été causée dans la ligne 346 du fichier /home/swpdev/public_html/groupe-gailleton.fr/wp-content/plugins/sitepress-multilingual-cms/classes/language-switcher/class-wpml-ls-settings.php. Message d’erreur : Uncaught Error: Call to undefined method stdClass::is_enabled() in /home/swpdev/public_html/groupe-gailleton.fr/wp-content/plugins/sitepress-multilingual-cms/classes/language-switcher/class-wpml-ls-settings.php:346 Stack trace: #0 /home/swpdev/public_html/groupe-gailleton.fr/wp-content/plugins/sitepress-multilingual-cms/classes/language-switcher/class-wpml-ls-inline-styles.php(274): WPML_LS_Settings->get_active_slots() #1 /home/swpdev/public_html/groupe-gailleton.fr/wp-content/plugins/sitepress-multilingual-cms/classes/language-switcher/class-wpml-ls-admin-ui.php(105): WPML_LS_Inline_Styles->admin_output() #2 /home/swpdev/public_html/groupe-gailleton.fr/wp-includes/class-wp-hook.php(288): WPML_LS_Admin_UI->admin_head_action('') #3 /home/swpdev/public_html/groupe-gailleton.fr/wp-includes/class-wp-hook.php(312): WP_Hook->apply_filters(NULL, Array) #4 /home/swpdev/public_html/groupe-gailleton.fr/wp-includes/plugin.php(478): WP_Hook->do_action(Array) #5 /home/swpdev/public_html/groupe-gailleton.fr/wp-admin/admin-

recuperation mode link :
hidden link

Best regards

Pascal

November 19, 2019 at 2:02 pm
November 19, 2019 at 2:03 pm #4973059

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello, welcome to the WPML support Forum!

I sent some instructions to replicate the website through a private message (previous answer). 

Please let me know if it worked for you. If so, please send us the instructions on how to see/reproduce the issue.

To ensure the quickest and most accurate support, please provide your debug information so that I can get a look at some of your configurations. We have an excellent article on how to located here: https://wpml.org/faq/provide-debug-information-faster-support/.

NOTE: Please be sure to check the box to indicate you can provide debug info and paste your debug info in the debug field provided, and NOT in the general response field.

November 19, 2019 at 3:26 pm #4973917

P-Derathe

Hello Diego
Before the migration I deleted the WPML files on hidden link
The I migrated the site to hidden link.
It works fine
Then I uploaded the sitepress-multilingual-cms.4.3.4.zip file
The site works fine
Then I activate the plugin .. and it breaks the site

Best regards
Pascal

November 19, 2019 at 7:52 pm #4975535

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you very much! The migration worked.

I'm doing some tests and will send you a feedback soon.

November 20, 2019 at 1:36 pm #4980807

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

The error is related to a deconfiguration of the language switcher (settings might be unserialized in a wrong way). I fixed it on our copy using the steps below:
- Backup the database
- Delete the wpml_language_switcher option from the wp_options table. You can find it using the following SQL query:

SELECT * FROM `gailleton_options` WHERE `option_name` LIKE 'wpml_language_switcher'

- After that, you can enable WPML without errors. It will regenerate the "wpml_language_switcher" option with default values

Please let me kinow if it worked for you.

November 20, 2019 at 2:28 pm #4981235

P-Derathe

Thanks Diego
I activated the WPML plugin on hidden link
Of course it brokes the site.
So I cleared the "wpml_language_switcher" in the Options table and then everything went OK

This is just a pitty that I need to go in phpmyadmin to make WPML works.

You may delete hidden link.

Best regards
Pascal

November 20, 2019 at 2:30 pm #4981239

P-Derathe

My issue is resolved now. Thank you!

November 20, 2019 at 2:37 pm #4981301

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

I'm glad to hear that the issue is solved 🙂

The copy site is deleted now: hidden link

Please contact us if you need our help in the future with WPML. We will be more than happy to help.

Cheers,
Diego