This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by janL-42 2 months ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
August 7, 2019 at 5:14 pm #4357113

janL-42

When I change a word in a source paragraph. I loose the whole translation in target and need to translate the whole sentence. I only want to add a word.

Is it possible to get the orginal translated text so I easily can add the word in target?

August 7, 2019 at 6:34 pm #4357441

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I am not sure if I understand your request into details, maybe a detailed step by step on how to reproduce your issue here, should be of help. In any case I found this resource for you: https://wpml.org/documentation/translating-your-contents/page-builders/preserving-existing-translations/. Can you please, let me know if it helps or if you need any additional instruction and help? I am happy and ready to help, have a nice day.

August 11, 2019 at 7:12 am #4376651

janL-42

Hello,
The problem is this : "Note that the translation will be lost if you update the text and the position of an element directly inside the page."

Is it possible to load the old text in to the translation box?

Example:
In danish: Dette er en simpel tekst.
Translated to english: This is a simple text.

Is I add a word to the danish sentence:
In danish: Dette er en meget simpel tekst.
Translation to english: <lost>

I would prefer to recall the orginal text "This is a simple text." and then I only have to add the word, "very".

In the example it will be "This is a very simple text."

August 12, 2019 at 6:13 pm #4383047

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. This is the exactly expected behavior mentioned in our instructions at: https://wpml.org/documentation/translating-your-contents/page-builders/preserving-existing-translations/ your already translated content should be preserved so you can just add your actual change you did in your default language content. I would need to replicate this issue in your website in order to understand what's happening in your particular case, for that, please consider: I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

August 13, 2019 at 6:45 am #4385361

janL-42

My issue is resolved now. Thank you!