This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: the plugin Front End PM uses a CSS for styling the language box, but this is not applied to the translated page

Solution: in Front End > Settings > Appearance > Load CSS file > choose "always". this will load the CSS file even in the translated page

This topic contains 30 replies, has 2 voices.

Last updated by hlaingM 5 months, 1 week ago.

Assigned support staff: Laura.

Author Posts
May 3, 2019 at 7:18 pm #3737589

hlaingM

I am trying to: apply language switch (from English to the secondary language)

Link to a page where the issue can be seen: Message box at hidden link (Please see the attached slides in order (from slide 1, slide 2 to slide 3)

I expected to see: the same organization in the message box (Front End PM Pro Plugin) as it is in the English language

Instead, I got: The organization collapses and the messages are not displayed properly.

May 4, 2019 at 9:33 am #3739639

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

thanks for contacting us.

I don't have enough information to answer your question.
There is a link where I can see the issue? I visited your site but I can't find the exact page you are referring to.

I would also need your WPML debug information. You can find it in:
WPML -> Support -> click on debug information link
Then you can copy/paste the text you see in the Debug box I'll enable for the next answer.
More information here: http://wpml.org/faq/provide-debug-information-faster-support/

May 4, 2019 at 9:57 am #3739791

hlaingM

Hi,

Thank you for your reply.

What you have to do is to login as one of the users on my website:

(1) Click "message box" on the top-bar of the menus
(2) Observe the messages organization: Then, switch to the secondary language by clicking the flag on the top-bar
(3) Once you clicked the flag, you will see the messages become disorganized
(4) Click one of those messages, you will see even more messed up interface of the message box. Please note that the interface looks fine with the default English language.

Where can I give you the username/password privately for you to have look at it?

Thank you.

May 4, 2019 at 10:02 am #3739801

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I'll enable a private answer for the credentials.
I understand the whole page is created with the plugin Front End PM Pro. Please notice this is not on our compatible plugin list so it might be a compatibility issue.

Would you be available to reproduce the issue in a fresh install? I'd give you the access.

May 4, 2019 at 10:27 am #3739871

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

yes, I can see the issue. It seems related to some kind of CSS that doesn't get copied in the second language.

With reproduce the issue, I mean installing the plugin on a fresh WordPress installation with only WPML and see if it happens the same. Now you tell me this is not possible.
How was your plugin customized? We cannot support custom plugins.

How is the "message box" translated? If you duplicate it first and then translate it independently does the situation improves?

May 4, 2019 at 10:43 am #3740001

hlaingM

Hi, Thank you for your response.

" installing the plugin on a fresh WordPress installation with only WPML and see if it happens the same"

-You meant with no "Front End PM Pro plugin"? With no plugin, you won't be able to see the message box. Or. maybe, I am not understanding what you meant.

If you install fresh Front End PM Pro, you will experience the same issues. It has nothing to do with the minor/tiny customization on the plugin.

"How is the "message box" translated? If you duplicate it first and then translate it independently does the situation improves?"
-I duplicate the "message box" item on the top-bar menus for the secondary language and translate it there. For the other contents of the "Front End PM Pro" plugin, I did string translation.

Please let me know if you have any questions. Thank you.

May 4, 2019 at 11:06 am #3740039

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I mean to install ONLY Front End PM Pro and WPML. If the issue is with the plugin, of course we have to install it.

Since I don't have a copy of Front End PM Pro nor I know how to use it, I'd ask you to configure it and reproduce the error here: hidden link

May 4, 2019 at 5:05 pm #3740801

hlaingM

Hi,

I am not able to reproduce the exact interface since I am a novice with the use of the wordpress and wpml. I just followed the documentations and what other WPML customer representatives told me to do the step-by-step setup instruction for the WPML.

I introduced the message box (FRONT END PM-free version) to your site, to the best of my ability. I sent about 5-6 messages using "demo" username via that message box .

FRONT END PM is free to download. The premium version (Front End PM Pro), the version I have, can be used only on one site.

hidden link

hidden link

I already described the step-by-step processes on how to reproduce the issues on my website.

May 4, 2019 at 5:35 pm #3740877

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I duplicated the Message box in the Sandbox but I can't see the issue: hidden link

From what I see on your site it seems a question of CSS or other HTML settings that aren't properly translated to the other language. You said you did some customization to this plugin, what did you do exactly? As I said, we cannot support custom coding so I need to be sure that what you did isn't related in any way to your issue.

May 4, 2019 at 5:47 pm #3740883

hlaingM

Hi, the interface you are seeing on your site is different from the interface you see on my site. That message box in connection with the language switch has not been set up in the exact way.

The tiny customization work has to do with the linking of the default "contact owner" button on the single ad listing with the plugin's message box page. It has nothing to do with the issues I have pointed out. To prove my point, I re-installed the Front End PM Pro plugin, tested it and I found the same issues.

May 6, 2019 at 7:19 am #3745413

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

where did you reinstalled the plugin?
It's possible to have the configuration in the Sandbox in the same way? We need to know what exactly is causing this behavior.
Could you also test with a default theme like TwentyNineteen? As I said, I think it's a CSS matter so it might be caused by the configuration in your theme.

If this doesn't help us, I'll take a copy of the site for further testing.

May 6, 2019 at 8:02 am #3745669

hlaingM

Hi,

A couple of days before I contacted you, I reinstalled the plugin without any customization to test what you are suspicious of, though there is no fundamental reason for the customization of the tiny part to cause that issue as told by my developer. And I found that the same issues occurred. Then, I restored my backup and showed you my site.

"It's possible to have the configuration in the Sandbox in the same way?"
-The answer is: Yes and No.

-Yes, the main thing relevant to the issue is the configuration, the setup and the appearance of that WPML language switch which the WPML technical representatives helped me with. I am not even able to reproduce the configurations by myself, except for restoring the backup. If you can set up the WPML correctly as it is on my site, then I think you can achieve the exact condition in this particular issue of context.

-No, you are not using the same theme. Plus, you are not using the paid version of the plugin which includes a few extra features. In addition, my paid version of the plugin has the license for one site ONLY.

"Could you also test with a default theme like TwentyNineteen?"
At the very best, I will get the same kind of configuration as I get on your site, since I am not an expert with wordpress and wordpress theme. I have to learn everything step-by-step. I once accidentally activated a theme like "TwentyNineteen" and my site crushed. It took me forever, talking to several different people in order to fix it and recover my original site.

Could you use the duplicator and test my site in the testing environment?

Thank you,

May 6, 2019 at 8:12 am #3745749

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I just sent a private reply with the instruction on how to create a copy of your site.
Please let me know when it's read so I can check it.

May 6, 2019 at 8:18 am #3745779

hlaingM

Hi,

Yes, I saw your private reply. Since I have never done this process, I have a question. It says "migration". Typically, "migration" means moving/cutting and pasting. I just want to confirm if the process is copying and pasting (but not cutting and pasting it onto a new domain). Thanks.

May 6, 2019 at 8:21 am #3745811

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

of course, we would never delete anything from our clients' servers. We choose this approach so we wouldn't need to access sites at all, so no, everything is just copied.