Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by svenA-8 1 year, 9 months ago.

Assigned support staff: Bobby.

Author Posts
February 19, 2019 at 7:40 am #3215287

svenA-8

I am trying to:

Built a history page with Elementor page builder, widget Timeline. When entering to translate it to 2nd language I'm seeing first of all "gearwheels" instead of a pencil. Secondly when entering on translations I'm only able to translate the upper part of the page (Title, Media, Headings, Anchor) but not viewing the actual content of the timeline built up.

Link to a page where the issue can be seen:

hidden link
hidden link

I expected to see:

Not sure how be able to view the "Timeline" in translations to translate it to 2nd language

Instead, I got:

February 19, 2019 at 2:46 pm #3217266

svenA-8

Did you receive my question ?

February 20, 2019 at 12:04 am #3219271

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hi There,

it sounds as if you are translating using the WPML Translation Editor.

if you wish to use the classic WP editor where you can view the page builder please go to
WPML->Settings->"translate manually"

since the translation shows with "gears" it means your translation is in progress please just go through the WPML Transaltion Editor translation , marking all the fields complete to get 100%, save and close and then when you access it again you should see the page builder

let me know your results

February 20, 2019 at 6:40 am #3220072

svenA-8

Hi Bobby

Thanks for your note. I want to translate the page using WPML Translation Editor as all other pages. But the issue is that when in translation mode I only see part of the page to translate (Title, Media, Heading). I've translated it and ticked boxes and is 100% now. But it is only very little part of whole page. I'm not prompted to translate the rest of the page, the actual "Timeline" widget used on that specific page. The "gears" are now gone but still am not able to see whole page in WPML Translation Editor to translate.

February 20, 2019 at 5:53 pm #3223299

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Please try the following as a test

go to the said page and open the edit page for the default language.

make a small adjustment , change and save the default language page

now you should either see a "loading icon" or a "gear icon" for the translation, open it and let me know if you see the rest of the options.

additionally , i understand you mentioned that what is not showing is the Timeline widget correct ?

how are you adding the widget? are you just adding the shortcode and then control the widget from the Appearance->Widgets page ? if so you will need to translate the widget directly in the Widgets page.

February 20, 2019 at 6:12 pm #3223325

svenA-8

Hi Bobby,

So I've went in into "edit" page both in WP as well as in with Elementor . Made minor changes, saved, etc. Getting "gears" when going back to the pages but when clicking on it still being 100% translated and still not seeing further down the page (timeline widget). Translation simply ends after media. Widget timeline (titles, dates, excerpts) not popping out for translation. Hopefully will not need to wait 7h for next reply. Thanks in advance

February 20, 2019 at 7:53 pm #3223547

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

I would like to take a closer look if possible

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

February 20, 2019 at 11:58 pm #3224141

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Thank you for the access details !

for the History page , you mentioned you are addding the time line as a widget

are you creating it within Elementors Templates ? If i go to Templates i can see a history one

if yes, please switch the option to "translatable" and translate the template there.

February 21, 2019 at 7:32 am #3225413

svenA-8

Hi Bobby

I don't understand. Could you be a bit more specific of where I should go and what exactly should do. The timeline widget did insert it on a "published" page when in Elementor page builder. Didn't create it in Template, or didn't "download" any template? I've tried different things but still just see "gears" and when entering still supposly 100% translated but missing still whole time line bit (the widget which is an element you can insert when constructing your page)

February 21, 2019 at 5:33 pm #3229245

svenA-8

Sorry but do I have to wait almost 24h before getting a response on something which I think is probably easy for your to help me with and could have been sorted on a quick chat ?

February 21, 2019 at 7:22 pm #3229694

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

My apologies it seems that we have some some time difference which is why there is a wait between our responses.

Additionally i have the credentials to the site therefore i have been doing specific tests to resolve this, as elementor is known to cause such issues with WPML and certain fields not getting picked up in translation.

At the moment i suggest going to the History page , and click on the button to deactivate translating with WPML Translation Editor, then access the Swedish translation and editing with Elementor, as this will allow you to add your Swedish translations to your widget

i have done this with the first image content title for Analytical Laboratories and it worked as expected .

The reason this is happening is because the Timeline widget is not one of the supported elements.
-> https://wpml.org/documentation/plugins-compatibility/elementor/#List-of-the-translatable-Elementor-Elements

If you rather not use the manual transaltion through Elementor as i suggested above then you can follow the guide here to add support to custom Elementor widgets

-> https://wpml.org/documentation/plugins-compatibility/elementor/how-to-add-wpml-support-to-custom-elementor-widgets/

February 22, 2019 at 11:15 am #3232018

svenA-8

My issue is resolved now. Thank you!