Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by alexisC-7 2 years, 5 months ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
October 22, 2018 at 3:17 pm #2838626

alexisC-7

I am trying to:deactivate media translation, remove translation meta from photos and see them back to wordpress admin with WPML media translation plugin deactivated. After this movement, every time i try to save media translation settings or (sometimes) try to add new settings on photo with Start button and some checkboxed checked i take an error.

Link to a page where the issue can be seen: hidden link (all the problem is to wordpress admin)

I expected to see: the photos back on wordpress media.

Instead, I got:empty wordpress media after plugin deactivation. Now i try to set media to be one for 2 languages and i take error from the save button. Also i have to activate plugin again to see some photos after plugin deactivation.

media-translation.JPG
October 22, 2018 at 8:06 pm #2839694

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

October 24, 2018 at 8:55 am #2845427

alexisC-7

I'm am sorry,but i can not give you access to the site because it is live and the GDPR regulations do not allow it. Please tell me why images are not shown in wordpress admin when we deactivate the media translation plugin. I understand that i add language informations to existing media but tell me how to revert this situation. I want to deactivate the media translation and have all my images to wordpress admin again or keep the media translation plugin activated, change media as not translatable and use one library for all languages.

October 24, 2018 at 7:07 pm #2847716

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. If you have a staging website of your live production website we can still debug the issue. In any case, let's proceed with some troubleshooting so we can identify the issue:

1 - Try to disable all the plugins except WPML's related ones (including the Media Translation addon). Now try to save your media settings again, do you still see the same issue?

2 - If the issue persists, try to switch to a default WordPress theme from your WordPress Dashboard > Appearance > Themes settings, the Twenty Seventeen default theme is a good fit here. Do you still see the same issue?

3 - If the issue persists, try to provide us with your server error logs, it will provide us with some meaningful message regarding the failed ajax request and the reason for that. You can use a private reply for the server error log contents.

Please, let me know if any of the steps above helps. Have a nice day.

October 29, 2018 at 2:47 pm #2858465

alexisC-7

Hello again, i transfer the website to another location and i can give you access to that wordpress. It show the same error. But i can't find the private reply.

October 29, 2018 at 7:16 pm #2859284

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I will enable the private reply option for you so you can send these details safely, for that, plase consider:

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

October 30, 2018 at 6:28 pm #2863294

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I peformed some tests in your WordPress Dashboard and could notice the issue. There's a bad request for ajax calls whenever the start or apply button for media is clicked which only a closer look in your server error log files would be of help to determine what's going on.

Unfortunately the FTP connection doesn't let me to browser to the server logs files, this way I would ask you to get in touch with your host in order to provide us with the error log contents. Usually the reason for any unsucessfull ajax request is recorded in these files and it is what would help us in this case. You can use the private reply to safely send us these contents.

Thank you for your collaboration and have a nice day.

October 31, 2018 at 7:59 am #2864656

alexisC-7

Thank you for your collaboration too!
I have access to logs and the Error is 'POST /wp-admin/admin-ajax.php?_fs_blog_admin=true HTTP/1.0' - Source: Apache access. I could also provide you the error logs but there is no option for private reply.

October 31, 2018 at 5:34 pm #2866970

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. It is needed to see the complete log contents, you can send your log file as a zip file if it is larger enough. I've enabled the private reply for you, you should see some field asking for a plugin or theme file, here you can send your log file as a zip file instead. Thank you for your collaboration and patience, have a nice day.

November 1, 2018 at 6:35 pm #2869627

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. The logs report some server permission issue, here we can determine the issue comes from your server configurations as the information at: hidden link indicates.

I recommend you to get in touch with your system administrator in order to troubleshooting these issues and review the server configurations. You find some more addditional resource for help at: https://stackoverflow.com/questions/18392741/apache2-ah01630-client-denied-by-server-configuration.

Hope it helps you to solve these issues. Have a nice day.

November 15, 2018 at 12:50 pm #2910150

alexisC-7

Our hosting supplier has solved the permissions issue however the problem still exists and they will try again with another solutions.
According to them, the problem has to do with your plugin because when you hit apply to save the changes an error 400 occurred regarding /wp-admin/admin-ajax.php wrong malfunction. Like empty action on ajax request. They are not sure because they don't have access neither in wordpress nor FTP. Further we would like you to check again FTP connection as it doesn't appear to be an access problem or create us a private message to send you new credentials. Thank you!