This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Andreas W. 6 months, 1 week ago.

Assigned support staff: Andreas W..

Author Posts
April 15, 2019 at 1:31 pm #3613769

yusufA-3

When I activate the WPML Multilingual CMS plugin, I cannot enter the wordpress admin panel. I'm getting a 500 error. Please help me. Now ı have inactive WPML Multilingual CMS plugin

April 15, 2019 at 6:14 pm #3615663

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting WPML Support.

Could you please try to run the site in minimal setup to see if the issue persists?

Please disable any additional plugin that is not related to WPML and its add-ons. If the issue disappears please start reactivating any plugins, or activate them in small groups. This way please verify at which points the issue appears again to indicate the plugin that is causing the issue.

Also please change to a default theme like TwentySeventeen to see if the issue might be theme related.

Further, you could enable the wp-debug feature to see if there are any current PHP errors given.
To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

define('WP_DEBUG', true);
In order to enable the error logging to a file on the server you need to add yet one more similar line:

define( 'WP_DEBUG_LOG', true );
In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

define( 'WP_DEBUG_DISPLAY', true );
The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

If you open wp-config.php and that define statement is not there, you can add it right before this line:

/* That's all, stop editing! Happy blogging. */

More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

Kind regards
Andreas

April 16, 2019 at 7:09 am #3618623

yusufA-3

Hi Andreas,
I hava taken this eror ıhave done everything but it still countinues.

Please help.

Warning: include(/home/mithatserhat/public_html/yenisite/wp-content/plugins/wpml-translation-management/vendor/composer/../../classes/xliff/class-wpml-tm-xliff-frontend.php): failed to open stream: No such file or directory in /home/mithatserhat/public_html/yenisite/wp-content/plugins/sitepress-multilingual-cms/vendor/composer/ClassLoader.php on line 444

Warning: include(): Failed opening '/home/mithatserhat/public_html/yenisite/wp-content/plugins/wpml-translation-management/vendor/composer/../../classes/xliff/class-wpml-tm-xliff-frontend.php' for inclusion (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/mithatserhat/public_html/yenisite/wp-content/plugins/sitepress-multilingual-cms/vendor/composer/ClassLoader.php on line 444

Fatal error: Class 'WPML_TM_Xliff_Frontend' not found in /home/mithatserhat/public_html/yenisite/wp-content/plugins/wpml-translation-management/classes/xliff/class-wpml-tm-xliff-factory.php on line 19

April 16, 2019 at 4:27 pm #3624029

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting WPML Support.

Please download the latest versions of WPML Multilingual CMS 4.2.5 at https://wpml.org/downloads.

Deactivate and delete all WPML plugins. Do not worry, this process will not affect your translations and settings stored in the database.

Add WPML Mulitlingual CMS 4.2.5 again.

Then go to Plugins -> Install -> Commercial and download the add-ons. Also, select the "Enable After Download" button at the bottom of the plug-in selector.

Please let me know if the issue has been resolved.

Kind regards
Andreas

April 17, 2019 at 5:42 am #3627205

yusufA-3

Hello firstly thank you for your help, I have done everything but when ı activate WPML Translation Management ı take same error 505: can you help me

April 17, 2019 at 4:31 pm #3632955

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Was there maybe another error mentioned in the debug.log that relates to another plugin?

Could you please try to run the site in minimal setup to see if the issue persists?

Please disable any additional plugin that is not related to WPML and its add-ons. If the issue disappears please start reactivating any plugins, or activate them in small groups. This way please verify at which points the issue appears again to indicate the plugin that is causing the issue.

Let me know if you are able to proceed those tests, otherwise I would like to offer myself to have a look at your site.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

The topic ‘[Closed] When I activate the WPML Multilingual CMS plugin, I cannot enter the wordpress a’ is closed to new replies.