This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Raja Mohammed 5 months, 2 weeks ago.

Assigned support staff: Raja Mohammed.

Author Posts
April 24, 2019 at 10:37 am

Stephanie

I am trying to:
activate woocommerce multilingual

Link to a page where the issue can be seen:
hidden link

I expected to see:
It working

Instead, I got:
It breaks the site

April 24, 2019 at 12:10 pm #3672477

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I am sorry that the issue is happening with our latest version of our plugin.

It would be good if you can provide me with the WordPress debug.log (not WPML debug information).

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

In this case, the errors will be saved to a debug.log log file inside the /wp-content/ directory.

If you can paste your debug.log to pastebin.com and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess in the discussion).

Please also share with using the server error logs in cases like internal error more information will be available in the server errors, It can be obtained from your Cpanel or check with your hosting provider.

We have also identified a timeout issue with our plugin can you please also try the workaround suggested in the errata https://wpml.org/errata/timeouts-with-woocommerce-multilingual-4-6-1/

I will be waiting for your response

Kind regards
Raja

April 25, 2019 at 6:27 am #3679041

Stephanie

Ok I managed to get a debug log, and here is the link (I hope it works - i have never used pastebin)

https://pastebin.com/FjE2ZFYs

The rest of your suggestion are too technical for me.

April 25, 2019 at 6:41 am #3679151

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Please share the FTP access for your site, I will try the patch suggested in the errata link.
I have enabled the private reply for you to securely share the details.

Kind regards
Raja

April 25, 2019 at 6:58 am
April 25, 2019 at 11:28 am #3681735

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I have applied the patch and activated the WooCommerce Multilingual, I am now able to access the site without any issues. Can you please confirm the same?

Kind regards
Raja

April 25, 2019 at 12:24 pm #3682287

Stephanie

Still not working correctly.....

hidden link

If i activate the plugin it goes to 500 server error
If i deactivate, it works.

And also when adding new product with attributes, it just keeps going in circles.
Also when trying to update translation of a product in woocommerce multilingual it just keeps going in circles.

April 25, 2019 at 1:42 pm #3682881

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

This seems like an issue which is already reported. To confirm, can you please provide us the server error log (not the WordPress debug log), In the error log do you see anything related to timeout or max_execution_time exhausted or please share the error log I will analyze and escalate the issue quick.

Kind regards
Raja

April 30, 2019 at 12:29 pm #3710975

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

We have release another patched version fixing the issue. Please update to the latest version of WooCommerce Multilingual to version 4.6.2.1.

I hope the update would solve the issue

Kind regards
Raja