This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 3 voices.

Last updated by Yvette 5 months, 1 week ago.

Assigned support staff: Yvette.

Author Posts
May 1, 2019 at 2:26 pm #3718535

tonyG-8

I am trying to: translate a page

Link to a page where the issue can be seen:

I expected to see:all of the fields to translate

Instead, I got: the complete progress fills over 90% of the view

May 1, 2019 at 6:20 pm #3719371

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. This seems to be some compatibility problem.

Please as a test, could you disable all non-WPML plugins, switch to the default theme and see if the problem persists?

If the problem is fixed, please, enable the plugins one by one to see if there is any compatibility problem between these plugins.

Thank you.

May 1, 2019 at 8:31 pm #3719841

tonyG-8

I have a copy of the site on the test server and that is performing fine using all the same plugins. When the translation was first created it was working fine but this only happened the translation page was saved, when not all the content was translated. This can't be a plugin compatibility issue otherwise it would be the same on the test server.

There must be another issue with the WPML plugin

May 1, 2019 at 8:38 pm #3719847

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

>>> This can't be a plugin compatibility issue otherwise it would be the same on the test server.

If it was a problem with WPML, this would happen in both installs. If it is working in one installation and not on the other, the problem cannot be WPML.

So I asked you to disable the plugins and switch to the default theme to see if this would work correctly.

Maybe it's some configuration with some other plugin. To know this, you would need to disable the non-WPML plugins and see how it will behave. Then activate the plugins one by one.

May 1, 2019 at 8:43 pm #3719865

tonyG-8

The issue is definitely with WPML. I checked the page and one element had a tick in the translation complete and this caused the issue. I unchecked the complete box for the one element and the complete block was back to normal. This seems to be the issue if only a few of the boxes are ticked. If you save the page with only partial translation then the bottom block showing the progress increases in size.

May 2, 2019 at 4:50 pm #3727247

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

As I can not replicate this problem in my testing environment, I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please let me know exactly what steps should I follow to see the problem.

*** Please, can I install the Duplicator plugin (or All in One Migration) to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

May 6, 2019 at 9:52 am #3746621

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

Bruno is not available so I will be taking over this issue. I hope you don´t mind.

I attempted to connect to your site but the username/passwd provided is not working when I cut&paste them into the login screen. Can you please re-check them? I am opening the private area again in case you need to provide new info.

Thanks

May 7, 2019 at 1:56 pm #3758961

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hmm - that is curious behaviour. Is it happening on all pages or just this one?

For this page, I went ahead and completed all the translaiton boxes so that it is now 100% complete. The progress bar is still a bit bigger than normal but it is at least manageable.

You should be able to go and correct/change any translations in that page now.

May 7, 2019 at 2:08 pm #3759125

tonyG-8

I gave you access to a test site. The live site still has the issue. What did you do to be able to get the translation to 100% complete. In the live site I can't see the last part to set it at 100%. In the live site I can't complete the translation. It also doesn't resolve the issue as when we need to add additional pages for translation we will have exactly the same issue. This looks like a bug in the plugin.

May 7, 2019 at 5:16 pm #3760971

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Here is what I did.

1. I installed a browser extension called "Check All"
2. I opened the translation and selected to copy all original values to the target language (only empty fields)
3. I then used the extension to check all as translated.
4. In my browser, I then had to uncheck a single string and then check it again to get the progress bar to 100%.
5. I then saved and closed the translation.

You did not answer my question regarding if this behaviour is only on this page or on all pages.
This is important.

We don´t seem to have any other reports of this kind of behaviour. Are you able to replicate it reliably on all servers? If not, it may be related to your server or installation specifically.

May 7, 2019 at 5:28 pm #3761005

tonyG-8

This does happen on all pages we try to translate and it happens on two separate servers, hosted in different locations. By the explanation you gave we would have to overwrite all the existing translations and enter them again, which is not ideal.
You also didn't give details of which browser the extension was for.

May 8, 2019 at 1:58 pm #3767433

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

1. Problem on all pages.
OK - this does sound like a WPML compatibility issue then.
Please see if you can replicate this behaviour on this clean installation. Just upload your theme and create a similar post.

Are you able to create a simple example that illustrates the issue?
Login: hidden link

2. Sorry, CHROME browser.

May 8, 2019 at 2:26 pm #3767725

tonyG-8

I added the theme oceanwp and elemntor and created a dummy page with a small amount of content. The issue was not evident.
However, I noticed that your sandbox is not using the latest version of WordPress. Also to really test your sandbox I would need to create a complex page with a lot of content to test it out. I don't have the time to do that at the moment. I may look at disabling plugins on my test site to see if that makes a difference.

May 8, 2019 at 2:59 pm #3767987

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

OK - that makes sense.

You could also try using Tools > Export/Import to just use the same post that you already have created on your own site.

Just to be sure.....

The topic ‘[Closed] when I am translating a page the complete progress fills 90% of the view’ is closed to new replies.