Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: After clicking the language switcher, the site would jump back to default language after a few seconds.

Solution: Updating to WPML 3.4 resolved this issue.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by Lauren 3 years, 10 months ago.

Assigned support staff: Lauren.

Author Posts
May 17, 2016 at 9:55 am #883955

jefM

Hey,

my website is this one: hidden link
On the top of the website (right), you see the language selector (NL and FR).

When I click on FR, the website jumps automatically back after two or three seconds.
Also, when I have my browser set to the french (FR) language, the website opens automatically in that language. that's all good, but somethimes the NL version first appears for a few seconds.

Is there a way to control this problem?

Thanks in advance!

Greetings,
Jef

May 17, 2016 at 4:56 pm #884380

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Hi jef, thank you for contacting WPML support. I'll be happy to help you with this.

This was a known issue that was resolved with our last release. Can you please update to WPML version 3.3.8 and let me know if this resolves the issue? Thanks!

May 18, 2016 at 8:51 am #884861

jefM

Hey,

now I updated all my WPML-plugins, but when I select FR as my browser language, it doesn't jump automatically to the FR language when I go to the website.
Can you test this?

Check my screenshot to see wich versions I'm using.

Thanks in advance!

May 18, 2016 at 9:23 am #884905

jefM

Hey,

I'm sorry, but I was too quick. the problem still occurs.
When I type in Google "Febecoop", and click on the first link, it all works fine. On a NL computer, I see the NL homepage, if I'm on a FR computer, I see the FR homepage.
But I think that's something Google does, not WPML.

Now, when I want to switch to the other language (so I click immediately on NL or FR), the website switches, and switches back after a few seconds.

Can you help me figger this out?

May 18, 2016 at 12:48 pm #885130

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

In your WPML -> Languages -> Browser Redirect settings, do you have browser redirect enabled? If so, then when you load the site, the site will redirect to the browser default language.

I just tested the site and it loads in NL for me and when I click FR, it loads the French site the first time without going back to NL. And I can click NL to get back to NL on the first try.

If this is still not working for you, try disabling browser redirect temporarily and see if the language switcher works as expected.

May 19, 2016 at 8:25 am #885815

jefM

Hey,

I tested and I think the problem is solved.
I will wait for the reaction of our partner, and then I will tell you if the problem is solved or not 🙂

Thanks for the help so far!

May 19, 2016 at 5:09 pm #886437

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks Jef! If it is resolved, you can close this thread. Otherwise, I will leave this open incase your partner reports any further issue.

June 3, 2016 at 7:27 am #896232

jefM

My problem still occurs...My client said the problem is still appearing, but if I do the test in a French browser, first the Dutch frontpage loads, than jumps to the French homepage. So that's good.
But is there a way to don't show the Dutch front page first, so jump immediatelly to the French page?

June 3, 2016 at 4:04 pm #897081

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Do you have a root page set up under WPMl -> Languages? If you have a root page and browser redirect, it should detect the browser language and load the correct site.

June 7, 2016 at 7:31 am #898675

jefM

Can I set a root page for each language?
I've set a root page in general for my website, or do I have to do more than that?

June 7, 2016 at 1:46 pm #900040

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

There can only be one root page because the root page does not have a language assigned to it.

I checked with our developers and currently there is no way to avoid seeing the default language load before the site redirects, as this is how our redirection works right now. It is on a list of feature requests so it may be changed in a future release.

Please let me know if you need any further assistance and I will be happy to help.

June 8, 2016 at 7:56 am #900626

jefM

Hey Lauren,

thanks for the information. Maybe it will be resolved soon. I want to say that it works fine somethimes on my computer, but our client keeps saying it doesn't appear well. But I'm almost sure it does 🙂

Thanks for the help and I will contact you again if I need further help.

Greetings,
Jef M.

September 30, 2016 at 9:41 pm #1106053

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Confirmed resolution