This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Shekhar Bhandari 2 months, 1 week ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
August 1, 2019 at 11:41 am #4321203

christophJ-11

When I click on the French flag on the start page (frFrançais (French)) my post is not in French ...

why is that?

in the other languages ​​it works fine ...

ask for quick help

best regards

August 2, 2019 at 8:21 am #4328009

christophJ-11

I discussed as yesterday. The Divi Theme up to date.

the described error still exists ...

As soon as I press on the homepage on the German or French flag I will not continue to the post, although a contribution is available ...

August 2, 2019 at 9:10 am #4328387

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

The post is not showing on the front-page as the post is not added to the front page at all if you open the front-page and edit the front page with divi builder you can see the content is different there? can you confirm it?

Look forward to your reply.

Thanks

August 2, 2019 at 9:52 am #4328703

christophJ-11

from the start page you come, by selecting the flag on the individual contributions in the national language.

see Italy or Spain

why it does not work for france, germany, slovakia and some more ...

I like to show it to you live via TeamViewer

August 2, 2019 at 11:38 am #4329671

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

We don't support TeamViewer, but I request you to create a video and share it with us so it will be more easy to understand the issue.

Look forward to your reply.

Thanks

August 2, 2019 at 3:11 pm #4331049

christophJ-11

hidden link

August 5, 2019 at 9:08 am #4339167

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

The video says it's unavailable, can you check it again?

Thanks

August 6, 2019 at 4:58 am #4344147

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I can see that German is your default language and you are viewing from the default language itself, so the German Flag link doesn't redirect to anywhere.

I can also see the other languages that have problems are the pages that are not translated in the backend. (screenshot attached of translated languages)

I can also see on the language switcher options you have used "In case of missing translations forward to the start page of the language" option which is adding those flags to the switcher and redirecting to the homepage, so I think the behavior you are having is normal.

If you don't want to show flags that are not translated and don't want to use redirect go to WPML->Langauges->Languages URL Format->How to handle non-translated content and enable "Skip Language"

Let me know if this help.

Thanks